Difference between revisions of "Talk:Fbsplash"

From ArchWiki
Jump to: navigation, search
(No fbsplash hook anymore: new section)
 
(10 intermediate revisions by 6 users not shown)
Line 1: Line 1:
The page says:
+
== Anything required for Systemd? ==
"to the bottom of your rc.conf."
+
  
Is it really rc.conf? I thought it should be /boot/grub/menu.lst or something?
+
Asking as it does not work properly for me with {{pkg|systemd}} v36, whereas it's just fine with the old {{pkg|initscripts}}:
  
Ah. The formatting was confusing. Fixing.
+
* No progress bar at boot
 +
* Won't switch to the login prompt at tty1.
 +
* Instead after fading out, the screen remains black for some sec, then the theme suddenly reappears.
 +
* The tty can then be called manually — but with an entirely wrong framebuffer resolution, apparently the smallest.
 +
* Nothing is displayed when rebooting/shutting down (as without fbsplash).
  
== Current state of fbsplash in Arch. ==
+
I'm using the binary Nvidia beta drivers, i. e. no KMS, without a fbcondecor-patched kernel.
  
Am I right in thinking that fbsplash is rather broken in Arch right now?
+
[[GRUB Legacy]] lines:
  
AUR page is [http://aur.archlinux.org/packages.php?do_Details=1&ID=13541&O=0&L=0&C=0&K=fbsplash&SB=n&SO=a&PP=25&do_MyPackages=0&do_Orphans=0&SeB=nd here].
+
kernel /boot/vmlinuz-linux root=/dev/disk/by-uuid/… resume=/dev/sda3 ro logo.nologo vga=794 splash=silent,fadein,fadeout,theme:arch-elegant init=/bin/systemd systemd.unit=multi-user.target quiet loglevel=3
  
--[[User:PeteLewis|PeteLewis]] 06:21, 17 August 2008 (EDT)
+
kernel /boot/vmlinuz-linux root=/dev/disk/by-uuid/… resume=/dev/sda3 ro logo.nologo vga=794 console=tty1 quiet loglevel=3 splash=silent,fadein,fadeout,theme:arch-elegant
 +
-- [[User:Misc|Misc]] 16:22, 10 October 2011 (EDT)
  
== No fbsplash hook anymore ==
+
:I experienced these problems too when I was using an fbcondecor patched kernel with the proprietary drivers (non-beta version) and initscripts. Nowadays, I'm on systemd, so testing this as well as the fbcondecor not applying to all ttys is going to be during my winter break.
 
+
:[[User:ShadowKyogre|ShadowKyogre]] ([[User talk:ShadowKyogre|talk]]) 20:23, 17 November 2012 (UTC)
I think the fbsplash hook was recently removed from fbsplash. Adding it to HOOKS will cause mkinitcpio to fail (because it can't find the script). —'''[[User:TedPavlic|TedPavlic]]''' ([[User_talk:TedPavlic|talk]]/[[Special:Contributions/TedPavlic|contrib]]/[[Special:EmailUser/TedPavlic|@]]) 11:01, 17 March 2010 (EDT)
+

Latest revision as of 20:23, 17 November 2012

Anything required for Systemd?

Asking as it does not work properly for me with systemd v36, whereas it's just fine with the old initscripts:

  • No progress bar at boot
  • Won't switch to the login prompt at tty1.
  • Instead after fading out, the screen remains black for some sec, then the theme suddenly reappears.
  • The tty can then be called manually — but with an entirely wrong framebuffer resolution, apparently the smallest.
  • Nothing is displayed when rebooting/shutting down (as without fbsplash).

I'm using the binary Nvidia beta drivers, i. e. no KMS, without a fbcondecor-patched kernel.

GRUB Legacy lines:

kernel /boot/vmlinuz-linux root=/dev/disk/by-uuid/… resume=/dev/sda3 ro logo.nologo vga=794 splash=silent,fadein,fadeout,theme:arch-elegant init=/bin/systemd systemd.unit=multi-user.target quiet loglevel=3
kernel /boot/vmlinuz-linux root=/dev/disk/by-uuid/… resume=/dev/sda3 ro logo.nologo vga=794 console=tty1 quiet loglevel=3 splash=silent,fadein,fadeout,theme:arch-elegant

-- Misc 16:22, 10 October 2011 (EDT)

I experienced these problems too when I was using an fbcondecor patched kernel with the proprietary drivers (non-beta version) and initscripts. Nowadays, I'm on systemd, so testing this as well as the fbcondecor not applying to all ttys is going to be during my winter break.
ShadowKyogre (talk) 20:23, 17 November 2012 (UTC)