Difference between revisions of "Talk:Fonts"

From ArchWiki
Jump to: navigation, search
(ttf-liberation package: re and closing)
(‘Set the proper key map’?: new section)
(One intermediate revision by one other user not shown)
Line 1: Line 1:
== <s>keymap modification needed?</s> ==
+
== &lsquo;Set the proper key map&rsquo;? ==
There should be a reference to [[KEYMAP]] on this page?<br>
+
-- [[User:Doru001|Doru001]] ([[User talk:Doru001|talk]]) 10:05, 4 March 2013 (UTC)
+
  
:I just added a link to [[KEYMAP]] under the related articles section.
+
FONT_MAP does not set the key map.
:-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 00:23, 5 March 2013 (UTC)
+
  
== <s>ttf-liberation package</s> ==
+
I put the following code into <TT >/etc/profile.d/locale.sh</TT >:
The article refers to the {{pkg|ttf-liberation}} package for the Liberation Sans Narrow font. But Liberation Sans Narrow is not included in the package.<br>
+
(case "${LANG}" in
-- [[User:DonJaime|DonJaime]] ([[User talk:DonJaime|talk]]) 12:01, 7 February 2013 (UTC)
+
pl_*) FONT=lat2-16;;
 +
*) let 0;;
 +
esac && setfont $FONT)
  
:You seem to be correct. I have removed it from the list. It would be nice to see a package get put in the AUR or for the font to get added to the package. I see that {{AUR|ttf-liberation1}} exists in the AUR. Maybe that package has it?
+
This allows the user to use a different locale than the system default. Of course, the list of supported languages must be extended.
:In any case, I'm closing this now.
+
 
:-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 00:36, 5 March 2013 (UTC)
+
--[[User:Yecril71pl|Yecril71pl]] ([[User talk:Yecril71pl|talk]]) 13:50, 11 May 2013 (UTC)

Revision as of 13:50, 11 May 2013

‘Set the proper key map’?

FONT_MAP does not set the key map.

I put the following code into /etc/profile.d/locale.sh:

(case "${LANG}" in
pl_*) FONT=lat2-16;;
*) let 0;;
esac && setfont $FONT)

This allows the user to use a different locale than the system default. Of course, the list of supported languages must be extended.

--Yecril71pl (talk) 13:50, 11 May 2013 (UTC)