Difference between revisions of "Talk:Install from existing Linux"

From ArchWiki
Jump to: navigation, search
(pacman.static, reorganized)
Line 1: Line 1:
== Suggestions ==
+
=== pacman.static ===
 +
 
 +
It's unclear whether pacman-static is still available anywhere but [http://aur.archlinux.org/packages.php?ID=19287 AUR]. See http://bbs.archlinux.org/viewtopic.php?id=59152 and http://bbs.archlinux.org/viewtopic.php?pid=727877 and http://bbs.archlinux.org/viewtopic.php?id=90685 and
 +
 
 +
pacman-static (3.2.2) isn't providing the xz archive format introduced with pacman 3.3.0...
 +
 
  
 
=== install with installer ===
 
=== install with installer ===
Line 28: Line 33:
  
 
--[[User:MSchmarck|MSchmarck]] 08:30, 21 April 2009 (EDT)
 
--[[User:MSchmarck|MSchmarck]] 08:30, 21 April 2009 (EDT)
 
== Comments ==
 
 
pacman-static (3.2.2) isn't provide the xz archive format introduced with pacman 3.3.0...
 

Revision as of 12:51, 19 March 2010

pacman.static

It's unclear whether pacman-static is still available anywhere but AUR. See http://bbs.archlinux.org/viewtopic.php?id=59152 and http://bbs.archlinux.org/viewtopic.php?pid=727877 and http://bbs.archlinux.org/viewtopic.php?id=90685 and

pacman-static (3.2.2) isn't providing the xz archive format introduced with pacman 3.3.0...


install with installer

Uhm. Afaik you can just install aif or archlinux-installer (deprecated) onto an existing arch system and just run it. Dieter_be

Prepare System

I had to recreate the device nodes, because they were not setup as displayed in the article. Could someone add a sentence on why those nodes might be created the wrong way? Without this explanation, this section leaves a somewhat irritating impression. Aku

/dev, uname and /sys missing at step "Install Base System"

During the "Install Base System" step, a lot of packages failed while doing "pacman -S ... base" with errors like this:

(  3/104) Aktualisiere glibc                        [#########################] 100%
ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or directory
/tmp/alpm_bOqjX0/.INSTALL: line 45: init: command not found
usr/sbin/locale-gen: line 16: rm: command not found
Generating locales...
Generation complete.

/tmp/alpm_hcjko9/.INSTALL: line 7: /dev/null: No such file or directory

I then re-did that step, but this time, I bind-mounted /dev, /sys & /proc from the host to the chroot which is going to be the new arch installation (ie. /newarch). And I did NOT do "pacman -S ... pacman", but instead just installed base, as base also contains pacman. However, BEFORE doing the "mount -o bind /dev /newarch/dev", it's important to create those 3 device files in /dev!

Result → No such error messages.

--MSchmarck 08:30, 21 April 2009 (EDT)