Difference between revisions of "Talk:Install from existing Linux"

From ArchWiki
Jump to: navigation, search
(/dev, uname and /sys missing at step "Install Base System": new section)
Line 7: Line 7:
  
 
I had to recreate the device nodes, because they were not setup as displayed in the article. Could someone add a sentence on why those nodes might be created the wrong way? Without this explanation, this section leaves a somewhat irritating impression. [[User:Aku|Aku]]
 
I had to recreate the device nodes, because they were not setup as displayed in the article. Could someone add a sentence on why those nodes might be created the wrong way? Without this explanation, this section leaves a somewhat irritating impression. [[User:Aku|Aku]]
 +
 +
== /dev, uname and /sys missing at step "Install Base System" ==
 +
 +
During the "Install Base System" step, a lot of packages failed while doing "pacman -S ... base" with errors like this:
 +
 +
(  3/104) Aktualisiere glibc                        [#########################] 100%
 +
ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or directory
 +
/tmp/alpm_bOqjX0/.INSTALL: line 45: init: command not found
 +
usr/sbin/locale-gen: line 16: rm: command not found
 +
Generating locales...
 +
Generation complete.
 +
 +
/tmp/alpm_hcjko9/.INSTALL: line 7: /dev/null: No such file or directory
 +
 +
I then re-did that step, but this time, I bind-mounted /dev, /sys & /proc from the host to the chroot which is going to be the new arch installation (ie. /newarch). And I did NOT do "pacman -S ... pacman", but instead just installed base, as base also contains pacman.
 +
 +
Result → No such error messages.

Revision as of 11:32, 21 April 2009

install with installer

Uhm. Afaik you can just install aif or archlinux-installer (deprecated) onto an existing arch system and just run it. Dieter_be

Prepare System

I had to recreate the device nodes, because they were not setup as displayed in the article. Could someone add a sentence on why those nodes might be created the wrong way? Without this explanation, this section leaves a somewhat irritating impression. Aku

/dev, uname and /sys missing at step "Install Base System"

During the "Install Base System" step, a lot of packages failed while doing "pacman -S ... base" with errors like this:

(  3/104) Aktualisiere glibc                        [#########################] 100%
ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or directory
/tmp/alpm_bOqjX0/.INSTALL: line 45: init: command not found
usr/sbin/locale-gen: line 16: rm: command not found
Generating locales...
Generation complete.

/tmp/alpm_hcjko9/.INSTALL: line 7: /dev/null: No such file or directory

I then re-did that step, but this time, I bind-mounted /dev, /sys & /proc from the host to the chroot which is going to be the new arch installation (ie. /newarch). And I did NOT do "pacman -S ... pacman", but instead just installed base, as base also contains pacman.

Result → No such error messages.