Difference between revisions of "Talk:Installing with Software RAID or LVM"

From ArchWiki
Jump to: navigation, search
(What about root on LVM ?)
(Lousy guide)
Line 50: Line 50:
  
 
--[[User:Suw|Suw]] 06:24, 8 April 2006 (EDT)
 
--[[User:Suw|Suw]] 06:24, 8 April 2006 (EDT)
 +
 +
== Lousy guide ==
 +
 +
This has to be the worst, most crappy designed guide i have seen in all of my time with OpenSource, restructure this thing, and strip the old stuff for 7.1, it is VERY outdated. I must say that i would feel more confident just jumping head on out into raid on my own, than following this guid, get som structure in it.

Revision as of 17:23, 4 May 2007

It was pointed out here: http://bbs.archlinux.org/viewtopic.php?p=121424#121495 that software RAIDing your swap is not useful, and even slows performance.

bug in /etc/rc.sysinit??

I think there is a problem with /etc/rc.sysinit as it not loads the module for the device mapper. This is lvm specific. I just modified the file like this:

if [ "$USELVM" = "yes" -o "$USELVM" = "YES" ]; then if [ -f /etc/lvmtab -a -x /sbin/vgchange ]; then

    # Kernel 2.4.x, LVM1 groups
    stat_busy "Activating LVM1 groups"
    /sbin/vgchange -a y
    stat_done
  elif [ -x /sbin/lvm -a -d /sys/block ]; then
    # Kernel 2.6.x, LVM2 groups
    stat_busy "Activating LVM2 groups"
    /sbin/modprobe dm_mod # <<-----Here is my change
    /sbin/lvm vgscan --ignorelockingfailure
    /sbin/lvm vgchange --ignorelockingfailure -a y
    stat_done
  fi

fi

i use the standard arch kernel

What about root on LVM ?

I can't figure out how to make it... mkinitrd variable LVM_ROOT= what to set here?? i am using grub and partition is like this:

  /dev/sda1 ext2 /boot
  /dev/sda2 LVM
        vg_name: linux
        lv_name:    system   /     ext3
                      home   /home ext3
                      swap   none  sw

I've tryed LVM_ROOT=/dev/linux/system, grub kernel ... root=/dev/mapper/linux-system or root=/dev/linux/system i have USELVM=YES and in initrd LVM is enabled...

lvm partitions was made with lvm2 - but i can activate and mount them manually where am i wrong??? - still blocked in bussybox with err - can't mount root - or so... or can't switch [don't remember] - lvm partitions are disabled - i have to enable and mount them manually

--Suw 06:24, 8 April 2006 (EDT)

Lousy guide

This has to be the worst, most crappy designed guide i have seen in all of my time with OpenSource, restructure this thing, and strip the old stuff for 7.1, it is VERY outdated. I must say that i would feel more confident just jumping head on out into raid on my own, than following this guid, get som structure in it.