Difference between revisions of "Talk:KVM"

From ArchWiki
Jump to: navigation, search
(kvm user group: re)
(kvm user group: re)
Line 37: Line 37:
 
::About the searching, I'd just check [https://wiki.archlinux.org/index.php?title=Special:Search&search=%22kvm%22%20%22group%22&fulltext=Search&profile=all&redirs=1], there are not that many results...
 
::About the searching, I'd just check [https://wiki.archlinux.org/index.php?title=Special:Search&search=%22kvm%22%20%22group%22&fulltext=Search&profile=all&redirs=1], there are not that many results...
 
::-- [[User:Lahwaacz|Lahwaacz]] ([[User talk:Lahwaacz|talk]]) 07:19, 7 November 2013 (UTC)
 
::-- [[User:Lahwaacz|Lahwaacz]] ([[User talk:Lahwaacz|talk]]) 07:19, 7 November 2013 (UTC)
 +
 +
:::I just fixed those two pages you linked. I haven't touched the search results link yet though.
 +
:::-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 19:07, 11 November 2013 (UTC)
  
 
== Works with "AMD FX(tm)-8350 Eight-Core Processor" using 2013.11.01 64-bit ==
 
== Works with "AMD FX(tm)-8350 Eight-Core Processor" using 2013.11.01 64-bit ==

Revision as of 19:07, 11 November 2013

Merge KVM article into QEMU

Because the QEMU-KVM fork of QEMU has been deprecated/obsoleted as of QEMU 1.3 [1] (about 9 months ago as of this writing [2]) and QEMU is now on version 1.6, we should strongly consider merging the KVM article into the main article for QEMU. A separate article for the KVM fork made sense historically, but now that the fork has been merged upstream, we should just keep everything on one page.

Does anyone disagree?
-- Jstjohn (talk) 16:29, 16 September 2013 (UTC)

Good idea, I don't think anybody can disagree, as the main section of this article, KVM#How_to_use_KVM, already just links to QEMU ^^
If then somebody considers QEMU to have become too long, it should be discussed to split it in some other way.
-- Kynikos (talk) 01:06, 18 September 2013 (UTC)
The problems of KVM#Tips_and_tricks should be solved along the way, especially KVM#Live_snapshots which belongs to libvirt and not to QEMU. It should also be clearly stated which features are KVM-specific to avoid confusion.
-- Lahwaacz (talk) 10:44, 22 September 2013 (UTC)
I just merged KVM#Live_snapshots into libvirt.
-- Jstjohn (talk) 01:03, 7 November 2013 (UTC)

kvm user group

Access to /dev/kvm is granted via ACLs:

/usr/lib/udev/rules.d/70-uaccess.rules
...
SUBSYSTEM=="misc", KERNEL=="kvm", TAG+="uaccess"
...

so adding the user to kvm group should be deprecated. There are many references to this all around the wiki.

-- Lahwaacz (talk) 11:12, 22 September 2013 (UTC)

I fixed as many instances of this that I could find. Is there a way to better search the wiki for remaining instances of this without using the regular search (regular search is pretty useless for something like this)?
-- Jstjohn (talk) 02:49, 7 November 2013 (UTC)
Thanks, but I'm not very sure about this one(s): [3]. The permissions there are not applied to /dev/kvm but to the newly created tap0 interface. The udev rule mentioned above is not applied here, so those scripts won't work in the current state. In this case I'd just use the user's primary group instead of kvm.
Also needs fixing: Systemd/Services#VDE2_interface.
About the searching, I'd just check [4], there are not that many results...
-- Lahwaacz (talk) 07:19, 7 November 2013 (UTC)
I just fixed those two pages you linked. I haven't touched the search results link yet though.
-- Jstjohn (talk) 19:07, 11 November 2013 (UTC)

Works with "AMD FX(tm)-8350 Eight-Core Processor" using 2013.11.01 64-bit

Using Arch Linux release 2013.11.01 in 64-bit mode... it boots fine. Following the wikis... this is basically the parameters I used

$ /usr/bin/qemu-system-x86_64 -boot d -m 1024 -hda '/home/user/path/to/storage' -cdrom '/path/to/archlinux-2013.11.01-dual.iso' -net nic,vlanx=0 -net user,vlan=0 -localtime -k en-gb -smp 8 -enable-kvm -cpu host &
  • I also booted the Gentoo minimal ISO 20131010 in 64-bit mode (go to gentoo to find out more) using the same parameter but different ISO
$ /usr/bin/qemu-system-x86_64 -boot d -m 1024 -hda '/home/user/path/to/storage' -cdrom '/path/to/install-amd64-minimal-20131010.iso' -net nic,vlan=0 -net user,vlan=0 -localtime -k en-gb -smp 8 -enable-kvm -cpu host &
  • During live CD boot up... I see this error message... which I think is normal...
Failed to access perfctr msr (MSR c0010001 is ffffffffffffffff)
  • You also get errors about not being able to access hardware... obvious why :p (unless I'm wrong)
  • I haven't installed Arch Linux in the guest yet (busy :p) but will get some time to
  • from what I can see, the parameter "nested" is already set to "1" for the kvm_amd module when using the systool command before applying the "nested" parameter myself
  • I found loading kvm or kvm_amd loads both
  • you should say grep svm /proc/cpuinfo for AMD
  • I have another AMD machine which has "AMD Phenom II x4 955" (showing the svm CPU flag from /proc/cpuinfo file which too is using Arch Linux (my server) when I have time... will try it out there
  • I do plan to move to Intel... better drivers... lets get cracking before I move to Intel
  • I'm new to wiki code :p

-- Sinatosk (talk) 22:34, 4 November 2013