Difference between revisions of "Talk:Kernel module package guidelines"

From ArchWiki
Jump to: navigation, search
(use https for links to archlinux.org)
Line 2: Line 2:
  
 
Because the version of kernel that is required to build a PKGBUILD and the currently installed kernel version could not match.
 
Because the version of kernel that is required to build a PKGBUILD and the currently installed kernel version could not match.
See [http://bugs.archlinux.org/task/6930 bug #6930]
+
See [https://bugs.archlinux.org/task/6930 bug #6930]

Revision as of 07:11, 28 April 2013

Why is the kernel version hard-coded in the PKGBUILDs? For users of custom compiled kernels it would be much easier if the hard-coded version would be replaced by $(uname -r). Rebuilding modules for custom compiled kernels would then be as easy as in gentoo.

Because the version of kernel that is required to build a PKGBUILD and the currently installed kernel version could not match. See bug #6930