Difference between revisions of "Talk:Libvirt"

From ArchWiki
Jump to: navigation, search
(Xen integration?: re)
m (QEMU/libvirt broke: rm closed discussion)
(One intermediate revision by the same user not shown)
Line 16: Line 16:
--[[User:En0|En0]] ([[User talk:En0|talk]]) 14:35, 10 December 2012 (UTC)
--[[User:En0|En0]] ([[User talk:En0|talk]]) 14:35, 10 December 2012 (UTC)
==<s>virt-manager 0.9.4 broken?</s>==
virt-manager-0.9.4-4 python scripts don't seem to be working. I have been testing them all day.. Including but not limited to a full clean reinstall of Arch 4 times.. I have been getting the error: Building default storage pool failed error. So as a work around I used is below.. This is after the directories are created and root has access to them.
# virsh
# pool-destroy default
# pool-undefine default
# pool-define-as --name default --type dir --target /path/to/default/directory
# pool-autostart default
# pool-build default
# pool-start default
# pool-destroy local
# pool-undefine local
# pool-define-as --name local-iso --type dir --target /path/to/default/local-iso/directory
# pool-autostart local-iso
# pool-build local-iso
# pool-start local-iso
# quit
$ virt-manager
--[[User:Rxdarkdawg10|Rxdarkdawg10]] ([[User talk:Rxdarkdawg10|talk]]) 21:17, 30 January 2013 (MST)
:I'm marking this as closed because this section is from 2013-01-30 and virt-manager is now on 0.10.0-4, so it is probably not relevant anymore.
:-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 02:57, 5 December 2013 (UTC)
==<s>QEMU/libvirt broke</s>==
Last version broke for me. It was a permissions issue that i solved by creating a service account.
I am running v1.0.2-1 with qemu.
Create service account for qemu:
<pre><nowiki># useradd -g kvm -M -N -r qemu</nowiki></pre>
Edit to run under creds: /etc/libvirt/qemu.conf
Also you will need to modify the permissions to the /dev/kvm
# chown root:kvm /dev/kvm
--[[User:En0|En0]] ([[User talk:En0|talk]]) 04:50, 31 January 2013 (UTC)
:I'm marking this as closed because libvirt is now on 1.2.0-1 and because systemd should automatically handle granting access to {{ic|/dev/kvm}}.
:-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 02:59, 5 December 2013 (UTC)
==KVM acceleration after removing qemu-kvm package==
==KVM acceleration after removing qemu-kvm package==

Revision as of 23:06, 11 February 2014

Xen integration?

What is the reasoning behind disabling Xen integration? I'm tempted to open a bug for the missing Xen integration, but I assume there is a reason it is excluded.

-- TripleSpeeder (talk) 14:43, 27 November 2012 (UTC)

I'm assuming that Xen integration is disabled because xenAUR is not in the official repositories. Even if an Arch user manages Xen VMs on remote systems (I'm assuming the remote systems are not running Arch), enabling Xen support in Arch's libvirt package isn't going to help because when you connect to a remote VM host, you are connecting to the remote host's libvirt daemon, so only the remote host would need libvirt to support Xen. You could open an issue on the bug tracker requesting that Xen support be enabled, but I'm guessing it won't happen.
-- Jstjohn (talk) 03:25, 5 December 2013 (UTC)

libvirt-guests and systemd

libvirt-guests does not work with systemd. At least not without modification to the scripts. To enable a guest to auto-start you can either check the "autostart" box in virt-manager, enable autostart through virsh or you can manually create a symlink in the libvirt auto-start directory.

To automatically start a guest named www that runs in qemu

ln -s /etc/libvirt/qemu/www.xml /etc/libvirt/qemu/autostart/www.xml

--En0 (talk) 14:35, 10 December 2012 (UTC)

KVM acceleration after removing qemu-kvm package

In order to have KVM acceleration after the removal of qemu-kvm I had to edit the config of my virtual machines like this:

<domain type='qemu' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>
    <qemu:arg value='-machine'/>
    <qemu:arg value='accel=kvm'/>
    <qemu:arg value='kernel_irqchip=on' />

I don't know if there is some specific field in libvirt XML, but this works for me.

--Vimes656 (talk) 13:16, 7 March 2013 (UTC)Vimes656

Chip-level IRQs

Added chip level IRQs to the argument list of Vimes656 recommendation.

--En0 (talk) 15:49, 7 March 2013 (UTC)

bridged network edit

note: sorry this is typed all lowercase (broken wrist)

im looking to do an edit on bridged networking section im looking for a suggestion as what to keep since netcfg is deprecated...

i pretty much want to layout how to set a bridge with netctl...


first find your network device to bridge...

ip a

it should be somthing along the lines of enpXXX

next create the bridge profile for netctl, then start and enable it

Description="Internet bridge"
netctl start br0
netctl enable br0


now this is where i need suggestions...is the current info relevant?

all i did was setup my vm to use br0 in virt-manager

i will go through these steps i used virt-manager but dont want to delete info if it isnt deprecate

(Sorry for your wrist)
Please don't delete anything if you're not sure of what you're doing: add templates like Template:Accuracy or Template:Out of date where appropriate instead. -- Kynikos (talk) 13:35, 16 July 2013 (UTC)
Kynikos, just wondering if the info is still relevant as i took a totally different approach with virt-manager, ill go ahead and post my relevant info, removing only the deprecated netcfg stuff --Dzavitz (talk) 06:21, 17 July 2013 (UTC)
Ok, just always remember to use the Edit Summary, thank you. -- Kynikos (talk) 08:28, 17 July 2013 (UTC)