Difference between revisions of "Talk:NetworkManager"

From ArchWiki
Jump to: navigation, search
(Fails to auto-connect: re, closing)
(Hostname_problems Entry: re)
Line 8: Line 8:
 
Rather then switch back to dhcpcd you could just have dhclient push the hostname.
 
Rather then switch back to dhcpcd you could just have dhclient push the hostname.
 
A la "send host-name" in the dhclient.conf. [[User:Ortango|Ortango]] ([[User talk:Ortango|talk]]) 18:57, 11 March 2013 (UTC)
 
A la "send host-name" in the dhclient.conf. [[User:Ortango|Ortango]] ([[User talk:Ortango|talk]]) 18:57, 11 March 2013 (UTC)
 +
 +
:I agree, especially the linked [https://bbs.archlinux.org/viewtopic.php?id=152376 forums thread] is confusing at least. It seems like a solution for a different problem with ''hostname problems'' only as a side effect. -- [[User:Lahwaacz|Lahwaacz]] ([[User talk:Lahwaacz|talk]]) 12:40, 21 August 2013 (UTC)
  
 
== <s>systemd</s> ==
 
== <s>systemd</s> ==

Revision as of 12:40, 21 August 2013

GNOME 3 and nm-applet

Looks like GNOME 3 doesn't need nm-applet any more. Moreover, it competes with the shell's network agent for new connections. Does anyone copy this? Should this be mentioned on the page?

Hostname_problems Entry

Isn't the suggested solution a little bit overkill? (Revert to using dhcpcd with NetworkManager) Also kind of assumes that dhclient is the problem. Which I do not believe to be the case. Rather then switch back to dhcpcd you could just have dhclient push the hostname. A la "send host-name" in the dhclient.conf. Ortango (talk) 18:57, 11 March 2013 (UTC)

I agree, especially the linked forums thread is confusing at least. It seems like a solution for a different problem with hostname problems only as a side effect. -- Lahwaacz (talk) 12:40, 21 August 2013 (UTC)

systemd

the openbox section still refers to /etc/rc.conf. Does the note still apply? --Qqqqqqqqq9 (talk) 18:01, 4 April 2013 (UTC)

Fixed, thanks for reporting. -- Lahwaacz (talk) 11:55, 21 August 2013 (UTC)

Fails to auto-connect

I was having an issue with getting NM to auto connect to known APs. I ran 'systemd-analyze blame' and found that I still had dhcpcd@<myadapter>.service enabled and it was taking a very long time to initialize. I disabled it, and now NM works perfectly. I noticed that in the wiki page it doesn't mention to disable this service, only to disable your previous wifi management system. Hope this helps! MagnumXopus (talk) 00:37, 24 July 2013 (UTC)

I added a note instead of the inaccurate section, systemctl --type=service will listt such services. -- Lahwaacz (talk) 12:34, 21 August 2013 (UTC)