From ArchWiki
Revision as of 07:51, 24 May 2014 by Kycok (Talk | contribs) (Move similar/related sections into parent sections: re)

Jump to: navigation, search

Split packages

This needs to be updated for split packages. Daenyth 22:55, 4 December 2009 (EST)

Variables/noextract about zip?

Isn't this information outdated? It seems bsdtar can now perfectly handle zip-files.

--Paolo 11:03, 8 September 2010 (EDT)

This information is still in the wiki. libarchive/bsdtar do support zip files. Are there some corner cases that libarchive's bsdtar cannot handle properly?
-- Jstjohn (talk) 04:55, 11 January 2014 (UTC)

package description

Note: Do not follow this rule thoughtlessly when submitting packages to AUR. If package name differs from application name for some reason, inclusion of full name into description can be the only way to ensure that package can be found during search.

I never had trouble with pre-/postfixed application names so the note doesn't apply to this case. Does it? Slopjong 03:19, 11 July 2012 (CEST)

I think the note leaves the decision up to the maintainer, and it seems reasonable to me. If you're intentioned to discuss the guidelines for PKGBUILDs, this is not the right place, please post in the forums or the mailing lists. -- Kynikos (talk) 12:28, 11 July 2012 (UTC)

Declare more mirrors for a file

Hello everyone, I have created the paragraph «Declare more mirrors for a file». Improvements/Suggestions? --Grufo [ contribs | talk ] 12:18, 22 November 2012 (UTC)

Forum thread created…:
--Grufo [ contribs | talk ] 01:35, 24 November 2012 (UTC)
This section has been removed. Discussion about source mirror lists in PKGBUILD on the aur-general ML. -- Karol (talk) 05:02, 11 January 2014 (UTC)

Move similar/related sections into parent sections

I think it would be useful to move PKGBUILD#md5sums, PKGBUILD#sha1sums, PKGBUILD#sha256sums.2C_sha384sums.2C_sha512sums into a parent section (e.g. named "Checksums") and leave only information specific to each variable in its given subsection. All 3 of these sections contain redundant information as they obviously all deal with the same thing: checksums.

This would also be useful for the four dependency related sections (depends, optdepends, makedepends, checkdepends), considering the edits I made here.

Thoughts? Opinions?

-- Jstjohn (talk) 04:16, 11 January 2014 (UTC)

I see a problem in the fact that currently all the child sections of #Variables are actual variable names, while after your proposed change that wouldn't be true anymore. Now, I agree that we should try to find a way to avoid duplication of content, so I propose to split the whole #Variables section in several top-level sections, like #Generic_variables, #Dependency_variables, #Checksum_variables (and more if we can identify more groups). -- Kynikos (talk) 03:54, 12 January 2014 (UTC)
+1 for splitting -- Kycok (talk) 07:51, 24 May 2014 (UTC)