Difference between revisions of "Talk:PostgreSQL"

From ArchWiki
Jump to: navigation, search
Line 20: Line 20:
 
Is step 4 correct? [[User:Elipsion|Elipsion]] 08:15, 13 January 2010 (EST)
 
Is step 4 correct? [[User:Elipsion|Elipsion]] 08:15, 13 January 2010 (EST)
 
*Good catch. Obviously it wasn't, datistemplate should've been set to TRUE for that database. Thanks for noticing it, I fixed it. --[[User:Cabrilo|Cabrilo]] 12:00, 13 January 2010 (EST)
 
*Good catch. Obviously it wasn't, datistemplate should've been set to TRUE for that database. Thanks for noticing it, I fixed it. --[[User:Cabrilo|Cabrilo]] 12:00, 13 January 2010 (EST)
 +
 +
Is this section still necessary?  I am just learning, but did a "show client_encoding" on template1 and it returns UTF8 out of the box. --[[User:Nitmd|Nitmd]] 11:55, 18 September 2010 (CDT)

Revision as of 16:56, 18 September 2010

Updated this wiki to make it more clear and up-to-date. -- Evanlec

Problem with installation

I tried to install postgresql with the wiki, but i found this problem: pg_ctl: PID file "/var/lib/postgres/data/postmaster.pid" does not exist Is server running?

I searched the forums and I found out that an instruction was missed to do:

$ initdb -D /var/lib/postgres/data/

I Hope this helps for this wiki


UTF-8

Added instructions on how to create new databases as unicode by default. This seems relevant as the default "encoding" SQL_ASCII is pretty useless for most people. --Cabrilo 06:15, 11 January 2010 (EST)

Is step 4 correct? Elipsion 08:15, 13 January 2010 (EST)

  • Good catch. Obviously it wasn't, datistemplate should've been set to TRUE for that database. Thanks for noticing it, I fixed it. --Cabrilo 12:00, 13 January 2010 (EST)

Is this section still necessary? I am just learning, but did a "show client_encoding" on template1 and it returns UTF8 out of the box. --Nitmd 11:55, 18 September 2010 (CDT)