Difference between revisions of "Talk:Ruby"

From ArchWiki
Jump to: navigation, search
m (Managing RubyGems using pacman: fix template)
m (Grammar fix.)
Line 1: Line 1:
 
==Managing RubyGems using pacman==
 
==Managing RubyGems using pacman==
The warning in [[Ruby#Managing_RubyGems_using_pacman]] implies that {{ic|--user-install}} and {{ic|--no-user-install}} options in a PKGBUILD file are bad. However, one of these switches '''must''' be present for a build to succeed. See the following:
+
The warning in [[Ruby#Managing_RubyGems_using_pacman]] implies that the {{ic|--user-install}} and {{ic|--no-user-install}} options in a PKGBUILD file are bad. However, one of these switches '''must''' be present for a build to succeed. See the following:
 
{{bc|<nowiki>
 
{{bc|<nowiki>
 
$ tail -n 1 /etc/gemrc
 
$ tail -n 1 /etc/gemrc

Revision as of 00:57, 3 April 2013

Managing RubyGems using pacman

The warning in Ruby#Managing_RubyGems_using_pacman implies that the --user-install and --no-user-install options in a PKGBUILD file are bad. However, one of these switches must be present for a build to succeed. See the following:

$ tail -n 1 /etc/gemrc
gem: --user-install
$ gem help install | tail -n 3
  Defaults:
    --both --version '>= 0' --document --no-force
    --install-dir /home/ichimonji10/.gem/ruby/2.0.0
$ curl http://pastebin.com/raw.php?i=xSQVUfDt > PKGBUILD
$ dos2unix PKGBUILD
$ makepkg
...
==> Starting package()...
ERROR:  Use --install-dir or --user-install but not both

Ichimonji10 (talk) 04:10, 1 April 2013 (UTC)