Difference between revisions of "Talk:Virtual user mail system"

From ArchWiki
Jump to: navigation, search
(Changed to dovecot, removing note about courier)
(Deleting old discussions that were about courier (we now use dovecot))
Line 3: Line 3:
 
Hey there, hopefully there are no problems while working down the guide. If there are, feel free to write them down here and I will come to them! However, please *do* try to correct any issues you find in the guide yourself if you can.
 
Hey there, hopefully there are no problems while working down the guide. If there are, feel free to write them down here and I will come to them! However, please *do* try to correct any issues you find in the guide yourself if you can.
 
--[[User:Svenstaro|Svenstaro]] 12:39, 19 September 2010 (EDT)
 
--[[User:Svenstaro|Svenstaro]] 12:39, 19 September 2010 (EDT)
 
== Tested successfully with PostgreSQL ==
 
 
I just installed pam_pgsql instead of pam_mysql.
 
 
And obviously replacing "mysql:" with "pgsql:".
 
 
The only problem I had is with "authpgsqlrc". It doesn't seem to accept hardcoded values like "5000" or "/home/vmail" so I left the default value for these fields and added them in my table schema with "5000" or "/home/vmail" as the default values.
 
 
Did that work? If yes, can you put instructions to the main guide? --[[User:Svenstaro|Svenstaro]] 00:52, 29 December 2010 (EST)
 
 
== Authentified relay? ==
 
 
Now I wonder how to set up STARTTLS/TLS in order to use my SMTP server from any IP using authentified access.
 
 
You mean you want to block/allow access based on IPs? Perhaps you should look into using ipchains or some other firewall there. --[[User:Svenstaro|Svenstaro]] 00:55, 29 December 2010 (EST)
 
 
== smtps doesn't work, additional step needed ==
 
 
Thank you for your work!
 
 
the postfix version is 2.8.0-2 here, and I followed the steps, got the mail server working successfully, but the smtps function didn't work. I found the solution in [[SOHO_Postfix#SMTP-AUTH]], /etc/postfix/master.cf should be edit.
 
 
the line begin with "smtps" is commented default, i uncomment that line and the following two lines, then restart postfix service, problem solved.
 
 
Oh, you are correct. It seems this changed in a recent release of this package. I'm changing the main article to reflect this. --[[User:Svenstaro|Svenstaro]] 00:29, 11 February 2011 (EST)
 

Revision as of 16:05, 5 June 2012

This is your friendly original author speaking.

Hey there, hopefully there are no problems while working down the guide. If there are, feel free to write them down here and I will come to them! However, please *do* try to correct any issues you find in the guide yourself if you can. --Svenstaro 12:39, 19 September 2010 (EDT)