Difference between revisions of "Talk:Skype"

From ArchWiki
Jump to: navigation, search
(Tomoyo)
m (Skype-OSS Sound (Pre-2.0): skype-oos no longer in repos)
Line 13: Line 13:
  
 
"If you have a recent version of Skype, this will not work and is not needed, look at the "important notes" on start of this page." -- the "important notes" section seems missing. -- [[User:Zag|Zag]] 13:13, August 6, 2012‎
 
"If you have a recent version of Skype, this will not work and is not needed, look at the "important notes" on start of this page." -- the "important notes" section seems missing. -- [[User:Zag|Zag]] 13:13, August 6, 2012‎
 +
 +
Just want to add that the mentioned package ''skype-oss'' is no longer available from the official repos. [[User:Stubentiger|Stubentiger]] ([[User talk:Stubentiger|talk]]) 08:53, 26 July 2013 (UTC)
  
 
== %wheel ALL=(skype) NOPASSWD: /usr/bin/skype ==
 
== %wheel ALL=(skype) NOPASSWD: /usr/bin/skype ==

Revision as of 08:53, 26 July 2013

What about skype phones? Is there a way to make them work with Linux? For instance, I have a Philips voip0801B/37. Are there open source drivers for these sort of things? -- Kc8tpz 11:58, October 1, 2007‎

Hey look if you can make it work as a generic kind/device type.
In regards to the other Linux distributions which would be the most likely to work with Arch? If you look at skype.com you will find packages for Debian, etc.. I've managed to get Flash Player in Arch x64 from using the ndiswrapper scripts from Ubuntu, any idea?
-- Dextrose 19:11, September 11, 2008‎

Troubleshooting

Hello, I've just found out that changing the permissions of libpulse, as the wiki recommends, breaks mplayer. I don't know if this is a peculiarity of my setup -- I doubt it --, but I would encourage other wiki users to try if this is the case, and if it is the section should be ammended. -- Manolomartinez 11:52, February 22, 2012‎

Skype-OSS Sound (Pre-2.0)

"If you have a recent version of Skype, this will not work and is not needed, look at the "important notes" on start of this page." -- the "important notes" section seems missing. -- Zag 13:13, August 6, 2012‎

Just want to add that the mentioned package skype-oss is no longer available from the official repos. Stubentiger (talk) 08:53, 26 July 2013 (UTC)

%wheel ALL=(skype) NOPASSWD: /usr/bin/skype

I have found that Skype runs as a special user if '%skype' is used instead of '%wheel'.

OSS status

This article mentions multiple times that OSS is 'deprecated' or that it only works on Skype <2.0. As said above (#Skype-OSS Sound (Pre-2.0)), important notes seem to be missing, explaining the status of OSS. Can somebody clarify this? Because if this is true it might be better to completely remove these sections. --Lonaowna (talk) 09:56, 22 May 2013 (UTC)

Tomoyo

I tried to secure Skype following the instructions in the article. Unfortunately it didn't work. Now i fixed it. For me to work, I needed a few modifications:

I added the following content to /etc/tomoyo/domain_policy.conf

file read /usr/share/locale/\*/LC_MESSAGES/\*
file read /usr/lib/gconv/\*

Otherwise skype doesn't adapt to the system language.

Furthermore just appending the in the article mentioned entries to /etc/tomoyo/exception_policy.conf doesn't work. Tomoyo didn't respect the lines
initialize_domain /usr/bin/skype from any
initialize_domain /usr/lib32/skype/skype from any
Therefore I moved them to the already existing entries of the form initialize_domain * in the configuration file. If this is also true for others, it might be a good idea to modify the article at least mentioning the latter one. Or perhaps it's a bug in tomoyo? --Marcus-aurelius (talk) 09:50, 8 June 2013 (UTC)