Difference between revisions of "Talk:Systemd"

From ArchWiki
Jump to: navigation, search
m (installation: add user's signature)
(marked as closed)
Line 23: Line 23:
 
::-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 21:38, 7 September 2012 (UTC)
 
::-- [[User:Jstjohn|Jstjohn]] ([[User talk:Jstjohn|talk]]) 21:38, 7 September 2012 (UTC)
  
== installation ==
+
== <s>installation</s> ==
  
 
a reboot using systemd is necessary before enabling services, which isn't mentioned in the installation overview.  I've added it, but if I'm incorrect on this feel free to revert it and (for my benefit) explain.<br>-- [[User:Limescout|Limescout]] ([[User talk:Limescout|talk]]) 04:07, 9 September 2012 (UTC)
 
a reboot using systemd is necessary before enabling services, which isn't mentioned in the installation overview.  I've added it, but if I'm incorrect on this feel free to revert it and (for my benefit) explain.<br>-- [[User:Limescout|Limescout]] ([[User talk:Limescout|talk]]) 04:07, 9 September 2012 (UTC)
 
* No need reboot for enabling services.
 
* No need reboot for enabling services.
 
:-- [[User:Unikum|Unikum]] ([[User talk:Unikum|talk]]) 10:03, 9 September 2012 (UTC)
 
:-- [[User:Unikum|Unikum]] ([[User talk:Unikum|talk]]) 10:03, 9 September 2012 (UTC)

Revision as of 21:41, 9 September 2012

initrd usage

If you are using an initrd without the udev hook, mounting of additional LVM partitions will fail during boot. Add udev to your mkinitcpio hooks and rebuild the initrd.
-- Ronnyyy (talk) 19:50, 6 June 2012 (UTC)

Display manager fails to load with fast SSD

I was having a problem with my display manager (LXDM) not loading on my laptop, which has a Sandisk Extreme SSD. Xorg.log would show errors like "No screens found."

I eventually figured out that the problem was that my computer was booting so fast that KMS didn't have enough time to kick in before X was started. I solved by adding the KMS driver (i915 in my case) to the initramfs.

Just a tip for SSD users, not sure if it should be added to the page or not.
--Steev (talk) 16:59, 2 September 2012 (UTC)

  • This is a general problem that needs to be solved in the display manager. GDM already implements the bits for the CanGraphical flag.
-- Falconindy (talk) 21:34, 2 September 2012 (UTC)

Bootloader kernel parameter

Should it be init=/bin/systemd or init=/usr/lib/systemd/systemd? I think the first one is recommended when you install systemd.
-- AdrianTM (talk) 04:02, 5 September 2012 (UTC)

  • You're right, pacman says /bin/systemd, which is a symlink to /usr/lib/systemd/systemd. Both might work, though I prefer to stick with the pacman message. Traced the wiki discrepancy back to this edit and the following ones.
--Emiralle (talk) 16:57, 5 September 2012 (UTC)
-- Jstjohn (talk) 21:38, 7 September 2012 (UTC)

installation

a reboot using systemd is necessary before enabling services, which isn't mentioned in the installation overview. I've added it, but if I'm incorrect on this feel free to revert it and (for my benefit) explain.
-- Limescout (talk) 04:07, 9 September 2012 (UTC)

  • No need reboot for enabling services.
-- Unikum (talk) 10:03, 9 September 2012 (UTC)