Difference between revisions of "Talk:Touchpad Synaptics"

From ArchWiki
Jump to: navigation, search
(Settings in xorg.conf/10-synaptics.conf don't seem to take effect)
(random left and right clicks)
Line 12: Line 12:
 
I am just speaking up as one of those users that are having problems with the touchpad cursor inexplicably jumping around.  Not only does it jump around, but it creates random left and right clicks when it jumps.  This happens while I am actually using the touchpad and not while typing as lots of others have been reporting around various forums.  Maddening.  At first it seemed to "calm down" over time (ie. time since reboot) but now seems to be pretty much constant.  If as you say there is currently no patch for this, it would be great to get a heads-up if and when the developers eventually get a handle on it.  Thanks very much...
 
I am just speaking up as one of those users that are having problems with the touchpad cursor inexplicably jumping around.  Not only does it jump around, but it creates random left and right clicks when it jumps.  This happens while I am actually using the touchpad and not while typing as lots of others have been reporting around various forums.  Maddening.  At first it seemed to "calm down" over time (ie. time since reboot) but now seems to be pretty much constant.  If as you say there is currently no patch for this, it would be great to get a heads-up if and when the developers eventually get a handle on it.  Thanks very much...
 
: --[[User:lucky_waster|lucky_waster]] 11:33, 20 June 2010
 
: --[[User:lucky_waster|lucky_waster]] 11:33, 20 June 2010
 +
 +
:Is this still an issue? I haven't had anything close to this in the past 3 versions of the driver. --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 11:54, 8 September 2012 (UTC)
  
 
== Settings in xorg.conf/10-synaptics.conf don't seem to take effect ==
 
== Settings in xorg.conf/10-synaptics.conf don't seem to take effect ==

Revision as of 11:54, 8 September 2012

problem with suspend/resume on tapping setting

I was using "synclient TapButton1=1" in a file which is run when I start GNOME to turn on tapping, but it was only working until the first time I suspended and resumed the system.

Searching for "synaptics archlinux tapping suspend" didn't bring me here very quickly - the article doesn't mention suspend or resume at all. The solution was to turn on tapping in the GNOME touchpad settings, as described in this article. It might be worth mentioning the problem with suspend/resume if we override settings 'on the fly'.

--Dooglus 01:24, 30 October 2011 (EDT)

I added a warning to the section covering on-the-fly configuration --stefanwilkens 19:43, 8 January 2012 (EST)

Re-highlighted the warning --stefanwilkens (talk) 23:13, 6 September 2012 (UTC)

random left and right clicks

I am just speaking up as one of those users that are having problems with the touchpad cursor inexplicably jumping around. Not only does it jump around, but it creates random left and right clicks when it jumps. This happens while I am actually using the touchpad and not while typing as lots of others have been reporting around various forums. Maddening. At first it seemed to "calm down" over time (ie. time since reboot) but now seems to be pretty much constant. If as you say there is currently no patch for this, it would be great to get a heads-up if and when the developers eventually get a handle on it. Thanks very much...

--lucky_waster 11:33, 20 June 2010
Is this still an issue? I haven't had anything close to this in the past 3 versions of the driver. --stefanwilkens (talk) 11:54, 8 September 2012 (UTC)

Settings in xorg.conf/10-synaptics.conf don't seem to take effect

I noticed that none of my settings changes in xorg.conf seemed to take any effect until I made sure the synaptics_i2c module was loaded. I'm not putting this into the page since it could've been a coincidence, but it's worth noting for anyone having problems. --Skarphace (talk) 05:21, 6 September 2012 (UTC)

You could be suffering a bug:
http://lists.opensuse.org/opensuse-bugs/2012-08/msg00455.html
Is your mouse completely dropping or is it just that settings made don't take effect? I take it you reload X / udev whenever you make changes? --stefanwilkens (talk) 23:23, 6 September 2012 (UTC)
I did some further digging, I believe this is GNOME overwriting your touch-pad settings. Have a look here and tell me if this solved it for you: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#GNOME --stefanwilkens (talk) 18:54, 7 September 2012 (UTC)