Difference between revisions of "Talk:Touchpad Synaptics"

From ArchWiki
Jump to: navigation, search
(Settings in xorg.conf/10-synaptics.conf don't seem to take effect)
(Settings in xorg.conf/10-synaptics.conf don't seem to take effect)
(3 intermediate revisions by 3 users not shown)
Line 1: Line 1:
== <s> problem with suspend/resume on tapping setting </s> ==
+
== <s> Settings in xorg.conf/10-synaptics.conf don't seem to take effect </s> ==
 
+
I was using "synclient TapButton1=1" in a file which is run when I start GNOME to turn on tapping, but it was only working until the first time I suspended and resumed the system.
+
 
+
Searching for "synaptics archlinux tapping suspend" didn't bring me here very quickly - the article doesn't mention suspend or resume at all.  The solution was to turn on tapping in the GNOME touchpad settings, as described in this article.  It might be worth mentioning the problem with suspend/resume if we override settings 'on the fly'.
+
: --[[User:Dooglus|Dooglus]] 01:24, 30 October 2011 (EDT)
+
I added a warning to the section covering on-the-fly configuration --[[User:Stefanwilkens|stefanwilkens]] 19:43, 8 January 2012 (EST)
+
 
+
Re-highlighted the warning --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 23:13, 6 September 2012 (UTC)
+
 
+
== <s> random left and right clicks </s> ==
+
I am just speaking up as one of those users that are having problems with the touchpad cursor inexplicably jumping around.  Not only does it jump around, but it creates random left and right clicks when it jumps.  This happens while I am actually using the touchpad and not while typing as lots of others have been reporting around various forums.  Maddening.  At first it seemed to "calm down" over time (ie. time since reboot) but now seems to be pretty much constant.  If as you say there is currently no patch for this, it would be great to get a heads-up if and when the developers eventually get a handle on it.  Thanks very much...
+
: --[[User:lucky_waster|lucky_waster]] 11:33, 20 June 2010
+
 
+
== Settings in xorg.conf/10-synaptics.conf don't seem to take effect ==
+
  
 
I noticed that none of my settings changes in xorg.conf seemed to take any effect until I made sure the {{ic|synaptics_i2c}} module was loaded.  I'm not putting this into the page since it could've been a coincidence, but it's worth noting for anyone having problems.
 
I noticed that none of my settings changes in xorg.conf seemed to take any effect until I made sure the {{ic|synaptics_i2c}} module was loaded.  I'm not putting this into the page since it could've been a coincidence, but it's worth noting for anyone having problems.
Line 23: Line 9:
 
:Is your mouse completely dropping or is it just that settings made don't take effect? I take it you reload X / udev whenever you make changes? --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 23:23, 6 September 2012 (UTC)
 
:Is your mouse completely dropping or is it just that settings made don't take effect? I take it you reload X / udev whenever you make changes? --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 23:23, 6 September 2012 (UTC)
 
::I did some further digging, I believe this is GNOME overwriting your touch-pad settings. Have a look here and tell me if this solved it for you: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#GNOME --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 18:54, 7 September 2012 (UTC)
 
::I did some further digging, I believe this is GNOME overwriting your touch-pad settings. Have a look here and tell me if this solved it for you: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#GNOME --[[User:Stefanwilkens|stefanwilkens]] ([[User talk:Stefanwilkens|talk]]) 18:54, 7 September 2012 (UTC)
 +
::: No response from user. Close. -- [[User:Fengchao|Fengchao]] ([[User talk:Fengchao|talk]]) 09:08, 18 February 2013 (UTC)
 +
 +
== ALPS touchpads ==
 +
 +
The article says that kernel 3.3 fixed the detection of ALPS touchpads (among others). I am running kernel 3.6.10 and my ALPS touchpad was not detected until I installed psmouse-alps-driver from the AUR. Therefore I suggest to rewrite the paragraph accordingly to say: "Some touchpads (e.g. ALPS, ...) need additional drivers to work. Install package X for touchpad Y." Any opposing arguments? [[User:Markus00000|Markus00000]] ([[User talk:Markus00000|talk]]) 19:12, 15 December 2012 (UTC)

Revision as of 09:08, 18 February 2013

Settings in xorg.conf/10-synaptics.conf don't seem to take effect

I noticed that none of my settings changes in xorg.conf seemed to take any effect until I made sure the synaptics_i2c module was loaded. I'm not putting this into the page since it could've been a coincidence, but it's worth noting for anyone having problems. --Skarphace (talk) 05:21, 6 September 2012 (UTC)

You could be suffering a bug:
http://lists.opensuse.org/opensuse-bugs/2012-08/msg00455.html
Is your mouse completely dropping or is it just that settings made don't take effect? I take it you reload X / udev whenever you make changes? --stefanwilkens (talk) 23:23, 6 September 2012 (UTC)
I did some further digging, I believe this is GNOME overwriting your touch-pad settings. Have a look here and tell me if this solved it for you: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#GNOME --stefanwilkens (talk) 18:54, 7 September 2012 (UTC)
No response from user. Close. -- Fengchao (talk) 09:08, 18 February 2013 (UTC)

ALPS touchpads

The article says that kernel 3.3 fixed the detection of ALPS touchpads (among others). I am running kernel 3.6.10 and my ALPS touchpad was not detected until I installed psmouse-alps-driver from the AUR. Therefore I suggest to rewrite the paragraph accordingly to say: "Some touchpads (e.g. ALPS, ...) need additional drivers to work. Install package X for touchpad Y." Any opposing arguments? Markus00000 (talk) 19:12, 15 December 2012 (UTC)