Difference between revisions of "Talk:VMware"

From ArchWiki
Jump to: navigation, search
(Tools Download Link: new section)
 
(46 intermediate revisions by 20 users not shown)
Line 1: Line 1:
== DKMS ==
+
== GUI doesn't show after upgrade ==
Is the section about using DKMS to compile the kernel modules still valid? There is [http://www.archlinux.org/packages/community/i686/open-vm-tools-dkms/ open-vm-tools-dkms] in the community repository which seems to be the same thing. I don't know how to use DKMS yet so it would be nice if someone with experience on using DKMS could update the corresponding section. --[[User:BertiBoeller|BertiBoeller]] ([[User talk:BertiBoeller|talk]]) 11:33, 2 October 2012 (UTC)
+
  
== Instability ==
+
I just wanted to record that the workaround listed here (export LD_LIBRARY_PATH...) does actually resolve the problem for Workstation 11.1.3 (I'm running on a 4.4.1 Kernel)
  
Anyone else experienced random kernel crashes when shutting down a VM? The stack trace always mentions XFS(which I use), but is never consistent. I'm on 9.0.0. Going to try upgrading to 9.0.1 to see if that helps it. --[[User:Earlz|Earlz]] ([[User talk:Earlz|talk]]) 23:03, 26 December 2012 (UTC)
+
I agree that the solution is not easily confirmed (I've read /usr/bin/vmware and there's nothing obvious why LD_LIBRARY_PATH is required) - but that's probably an issue to be taken to VMware, rather than reported in depth here.
:So did it? --[[User:Det|Det]] ([[User talk:Det|talk]]) 14:18, 26 February 2013 (UTC)
+
  
== Long term include fix for Linux 3.7? ==
+
This workaround is not easily found on the rest of the internet and I have been struggling to get this working for a while (on & off..), so it is definitely a good idea to keep this section here.
  
Is there any kind of long term fix for the moved {{ic|version.h}}? It's a pain having to redo that symlink on every kernel upgrade. --[[User:Earlz|Earlz]] ([[User talk:Earlz|talk]]) 15:14, 13 February 2013 (UTC)
+
[[User:RuneArch|RuneArch]] ([[User talk:RuneArch|talk]]) 09:15, 18 February 2016 (UTC)
 +
 
 +
:Hi, I have this same issue with vmware where the GUI won't show, but If I try the trick in this section of the wiki, it tells me modules have to rebuild, but nothing happens after https://wiki.archlinux.org/index.php/VMware#GUI_doesn.27t_show_after_upgrade. I still get this output: http://slexy.org/view/s2lgjglqrN
 +
:[[User:Professorkaos64|Professorkaos64]] ([[User talk:Professorkaos64|talk]]) 20:56, 5 July 2016 (UTC)
 +
 
 +
::I'm using version WS 12.5 with kernel 4.8, searching all pages in many days, then just need add one line: "export VMWARE_USE_SHIPPED_LIBS=force" in /usr/bin/vmware. The solution comes from https://bugzilla.redhat.com/show_bug.cgi?id=1278896#c3. It works for me. Hope this help.
 +
::[[User:pacman]] Oct 23 15:24:53 UTC 2016
 +
 
 +
== Tools Download Link ==
 +
 
 +
If anyone facing an issue with vmware tools, like could not install component, you can manually download tools from vmware.
 +
 
 +
http://softwareupdate.vmware.com/cds/vmw-desktop/ws/
 +
 
 +
Just shared so someone can find it usefull ;-)

Latest revision as of 04:00, 28 November 2016

GUI doesn't show after upgrade

I just wanted to record that the workaround listed here (export LD_LIBRARY_PATH...) does actually resolve the problem for Workstation 11.1.3 (I'm running on a 4.4.1 Kernel)

I agree that the solution is not easily confirmed (I've read /usr/bin/vmware and there's nothing obvious why LD_LIBRARY_PATH is required) - but that's probably an issue to be taken to VMware, rather than reported in depth here.

This workaround is not easily found on the rest of the internet and I have been struggling to get this working for a while (on & off..), so it is definitely a good idea to keep this section here.

RuneArch (talk) 09:15, 18 February 2016 (UTC)

Hi, I have this same issue with vmware where the GUI won't show, but If I try the trick in this section of the wiki, it tells me modules have to rebuild, but nothing happens after https://wiki.archlinux.org/index.php/VMware#GUI_doesn.27t_show_after_upgrade. I still get this output: http://slexy.org/view/s2lgjglqrN
Professorkaos64 (talk) 20:56, 5 July 2016 (UTC)
I'm using version WS 12.5 with kernel 4.8, searching all pages in many days, then just need add one line: "export VMWARE_USE_SHIPPED_LIBS=force" in /usr/bin/vmware. The solution comes from https://bugzilla.redhat.com/show_bug.cgi?id=1278896#c3. It works for me. Hope this help.
User:pacman Oct 23 15:24:53 UTC 2016

Tools Download Link

If anyone facing an issue with vmware tools, like could not install component, you can manually download tools from vmware.

http://softwareupdate.vmware.com/cds/vmw-desktop/ws/

Just shared so someone can find it usefull ;-)