Difference between revisions of "Talk:Yaourt"

From ArchWiki
Jump to: navigation, search
(deal with package replacement?)
(Deal with package replacement?: closed)
Line 12: Line 12:
 
:I've not seen any problems either, nor has anybody else that I know use Yaourt daily.  However, on the AUR page, there are comments about it having problems with the latest AUR, though the comments don't go into detail.  Since the last release was in May 2009, if the bug was in place in january, that still hasn't changed.  It probably would be good to find the exact problem, and say, "Yaourt release has broken feature foo-bar, use Yaourt git if you need this..." [[User:Pierre Monteux|Pierre Monteux]] 10:37, 13 March 2010 (EST)
 
:I've not seen any problems either, nor has anybody else that I know use Yaourt daily.  However, on the AUR page, there are comments about it having problems with the latest AUR, though the comments don't go into detail.  Since the last release was in May 2009, if the bug was in place in january, that still hasn't changed.  It probably would be good to find the exact problem, and say, "Yaourt release has broken feature foo-bar, use Yaourt git if you need this..." [[User:Pierre Monteux|Pierre Monteux]] 10:37, 13 March 2010 (EST)
  
==Deal with package replacement?==
+
==<s>Deal with package replacement?</s>==
 
The article states twice that yaourt shouldn't be used to manage official packages because of issues with replacements:
 
The article states twice that yaourt shouldn't be used to manage official packages because of issues with replacements:
  
Line 26: Line 26:
  
 
I would remove those statements, as I think they do not belong here. -- [[User:Kynikos|Kynikos]] 07:20, 4 July 2011 (EDT)
 
I would remove those statements, as I think they do not belong here. -- [[User:Kynikos|Kynikos]] 07:20, 4 July 2011 (EDT)
 +
:Statements have been removed: [https://wiki.archlinux.org/index.php?title=Yaourt&action=historysubmit&diff=167537&oldid=167369] and [https://wiki.archlinux.org/index.php?title=Yaourt&diff=next&oldid=167539]. Closing. -- [[User:Kynikos|Kynikos]] 08:21, 6 November 2011 (EST)

Revision as of 13:21, 6 November 2011

Regarding general opinion on yaourt

A great deal of people still ask for yaourt support, even though more recent helpers have less issues that outright break installing from AUR, and less problems that degrade performance. Maybe the article should reflect what is actually happening; people are pointing towards others like packer and bauerbill. Dres 23:13, 26 January 2010 (EST)

  • I wasn't the person who removed your comment about Yaourt being unmaintained, but the most recent changelog is on 17 Aur 2009. That seems pretty recent to me.

    I don't think it's a good idea to add information about other AUR helpers on the Yaourt page. The Yaourt page should only give information about Yaourt. If we add information about Packer or Bauerbill then it will just look like we are advertising another AUR helper. :P

    It's strange how new Arch Linux users seem to just "know" that they should use Yaourt. It happened to me: I have been using Arch Linux for less than a year, and when I wanted to start using the AUR, I used Yaourt. The funny thing is, I don't even remember where I learned that I should use Yaourt.

    I think as people start moving away from suggesting Yaourt in the wiki documentation and in the Arch Linux forums, people will begin to use other AUR helpers. The best thing is when people use the best program for the job they want to do, even if it is Yaourt. ;) drcouzelis 17:17, 12 March 2010 (EST)

Prefer yaourt-git ?

I'm kinda intrigued by this line, I am using the "normal" yaourt from the AUR and do not seems to have any trouble, what kind of features are broken ? Is there a risk for my system if I keep using this "broken" yaourt ?

I can see that the last edit was late january 2010, almost a century in computing :) Is it still true ?

I've not seen any problems either, nor has anybody else that I know use Yaourt daily. However, on the AUR page, there are comments about it having problems with the latest AUR, though the comments don't go into detail. Since the last release was in May 2009, if the bug was in place in january, that still hasn't changed. It probably would be good to find the exact problem, and say, "Yaourt release has broken feature foo-bar, use Yaourt git if you need this..." Pierre Monteux 10:37, 13 March 2010 (EST)

Deal with package replacement?

The article states twice that yaourt shouldn't be used to manage official packages because of issues with replacements:

"Please bear in mind that yaourt does not presently deal with package replacement. Using it to update the system is not recommended."

"You should use pacman for anything not related to the AUR, because yaourt may not fully take care of necessarily steps such as replaces."

However, AFAIK that is indeed a problem of pacman itself (FS#24904), and yaourt suffers of it only because it's a wrapper for pacman, which means that it uses the currently installed version of pacman for managing packages, only adding and coloring some output, and providing the ability to download and build AUR packages (but not installing the built packages, which again is done with a pacman call). This is proved also by the fact that in /etc/yaourtrc you have to specify the command to use to manage packages:

# Command
PACMAN=pacman #could be "pacman-color" or even something else
#DIFFEDITCMD="vimdiff"

I would remove those statements, as I think they do not belong here. -- Kynikos 07:20, 4 July 2011 (EDT)

Statements have been removed: [1] and [2]. Closing. -- Kynikos 08:21, 6 November 2011 (EST)