Difference between revisions of "User:Romashka"

From ArchWiki
Jump to: navigation, search
Line 1: Line 1:
 
= TODO =
 
= TODO =
 +
 +
== bugs and features in packages ==
 
* [http://bugs.archlinux.org/task/3810 FR #3810] - hddtemp daemon script
 
* [http://bugs.archlinux.org/task/3810 FR #3810] - hddtemp daemon script
 +
 +
= Pacman  =
 +
* review libalpm's add.c and remove.c
 +
** use <code>[PATH_MAX+1]</code> instead of <code>[PATH_MAX]</code> in remove.c
 +
** rename <code>info</code> to <code>pkg</code> in *_commit ?
 +
** make sure of consistent and correct use of:
 +
*** <code>scriptlet</code> vs <code>newpkg->data</code>
 +
*** <code>newpkg->name</code> vs <code>alpm_pkg_get_name(newpkg)</code>

Revision as of 15:45, 7 April 2007

TODO

bugs and features in packages

Pacman

  • review libalpm's add.c and remove.c
    • use [PATH_MAX+1] instead of [PATH_MAX] in remove.c
    • rename info to pkg in *_commit ?
    • make sure of consistent and correct use of:
      • scriptlet vs newpkg->data
      • newpkg->name vs alpm_pkg_get_name(newpkg)