Difference between revisions of "Wayland"

From ArchWiki
Jump to: navigation, search
(Update GTK3 section)
m (GTK+: mention fix for libcanberra)
Line 81: Line 81:
 
When both Wayland and X backends are enabled, GTK+ will default to the X11 backend, but this can be overridden by setting the <code>GDK_BACKEND</code> environment variable to <code>wayland</code>.
 
When both Wayland and X backends are enabled, GTK+ will default to the X11 backend, but this can be overridden by setting the <code>GDK_BACKEND</code> environment variable to <code>wayland</code>.
  
Remove {{pkg|libcanberra}} if you get segmentation faults when running gtk applications.
+
Remove {{pkg|libcanberra}} if you get segmentation faults when running gtk applications. A [http://git.0pointer.de/?p=libcanberra.git;a=commit;h=c0620e432650e81062c1967cc669829dbd29b310 fix] for these segfaults has been committed as of 9 Nov 2012, so presumably as soon as 0.31.0 comes out, this should not be necessary anymore.
  
 
===Clutter===
 
===Clutter===

Revision as of 10:31, 9 March 2013

Template:Article summary start Template:Article summary text Template:Article summary heading Template:Article summary wiki Template:Article summary wiki Template:Article summary end

Wayland is a new windowing protocol for Linux. Utilization of Wayland requires changes to and re-installation of parts of your system's software. For more information on Wayland see its homepage.

Warning: Wayland is under heavy development. Support can not be guaranteed and it may not function as you expect.

Requirements

Currently Wayland will only work with on a system that is utilizing KMS.

Installation

Wayland is most probably installed on your system already as it is an indirect dependency of gtk2 and gtk3. If it is not installed, you will find the wayland package in extra.

Usage

As Wayland is only a library, it is useless on its own. To use it, you need a compositor (like Weston), Weston demo applications, Qt5 (or Qt4 with QPA enabled) with Wayland plugin, and/or GTK+ with Wayland support.

Weston

Installation

You need to install weston from community.

Note: If you get the following error: "Failed to create XKB context", install xkeyboard-config: # pacman -S xkeyboard-config

Usage

Now that Wayland and its requirements are installed you should be ready to test it out. Try switching to a terminal and running:

$ weston-launch
Note: There may be some trouble with keyboard & mouse not working unless this is ran as root.

You may also try exporting the following, if having problems with hardware drivers:

$ export EGL_DRIVER=/usr/lib/egl/egl_gallium.so

Then at a TTY you can run the demos. To launch a terminal emulator:

$ weston-terminal

To move flowers around the screen:

$ weston-flower 

To test the frame protocol (runs glxgears):

$ weston-gears

To display images:

$ weston-image image1.jpg image2.jpg...

To display PDF Files:

$ weston-view doc1.pdf doc2.pdf...

Qt

Installation

You need to install qt5-base.

Usage

At first, you need a working Wayland compositor, like the one from demo applications, or an experimental version of KWin.

Then compile any qmake-based Qt project:

$ qmake
$ make

And run it by executing the compiled binary:

$ export QT_QPA_PLATFORM=waylandgl
$ ./binaryname

Qt Compositor

There is ongoing work to make Qt-Compositor, a base layer to make custom Qt compositors on top of Wayland.

Other GUI libraries

(page from official website)

GTK+

You need to install gtk3 from testing, which has the Wayland backend enabled.

With GTK+ 3.0, GTK+ gained support for multiple backends at runtime and can switch between backends in the same way Qt can with lighthouse.

When both Wayland and X backends are enabled, GTK+ will default to the X11 backend, but this can be overridden by setting the GDK_BACKEND environment variable to wayland.

Remove libcanberra if you get segmentation faults when running gtk applications. A fix for these segfaults has been committed as of 9 Nov 2012, so presumably as soon as 0.31.0 comes out, this should not be necessary anymore.

Clutter

The Clutter toolkit has a Wayland backend that allows it to run as a Wayland client. The backend is in the master branch of the main repo and can be activated by passing --with-flavour=wayland to the configure script.

SDL

Benjamin Franzke is working on a port of SDL to Wayland, it's available in his sdl-wayland repo on freedesktop.org. Further development upon Benjamins work was done by Andre Heider in his wayland branch of libsdl.

EFL

EFL has complete Wayland support. Please see here for details.

Window managers and desktop shells

KDE

There is early work to make it possible to run KWin (KDE's window manager) on Wayland.

GNOME

GNOME will be ported to Wayland in a future version.

Unity

Ubuntu desktop shell Unity, using Compiz window manager, was announced to be ported to Wayland.


Pure Wayland

Warning: Some really quick notes on installing a pure (no X11) wayland system on Arch Linux. This is from source and installed into /usr/local. May break your system. You have been warned. (by elethiomel@gmail.com)

First install a base Arch Linux install with base and base-devel. Do not install xorg or any of its libraries


Wayland
$ pacman -S libffi
$ git clone git://anongit.freedesktop.org/wayland/wayland
$ cd wayland
$ ./autogen.sh --prefix=/usr/local
$ make
$ make install
DRM and Mesa
$ git clone git://anongit.freedesktop.org/git/mesa/drm
$ cd drm
$ ./autogen.sh --prefix=/usr/local
$ make
$ make install
$ git clone git://anongit.freedesktop.org/mesa/mesa
$ cd mesa
$ CFLAGS=-DMESA_EGL_NO_X11_HEADERS ./autogen.sh --prefix=/usr/local --enable-gles2 --disable-gallium-egl --with-egl-platforms=wayland,drm --enable-gbm --enable-shared-glapi --with-gallium-drivers=r300,r600,swrast,nouveau --disable-glx --disable-xlib
$ make
$ make install
xorg-macros
$ git clone http://anongit.freedesktop.org/git/xorg/util/macros.git
$ cd macros/
$ ./autogen.sh --prefix=/usr/local/
$ make
$ make install
libxkbcommon
$ git clone git://people.freedesktop.org/xorg/lib/libxkbcommon.git
$ cd libxkbcommon/
$ export ACLOCAL_PATH=/usr/local/share/aclocal/
$ ./autogen.sh --prefix=/usr/local/ --with-xkb-config-root=/usr/local/share/X11/xkb
$ make
$ make install
pixman
$ git clone git://anongit.freedesktop.org/pixman
$ cd pixman/
$ ./autogen.sh --prefix=/usr/local/
$ make
$ make install
 
cairo

Note - no glx/gl or xcb - EGL only.

$ pacman -S libpng
$ git clone git://anongit.freedesktop.org/cairo
$ cd cairo
$ CFLAGS=-DMESA_EGL_NO_X11_HEADERS ./autogen.sh --prefix=/usr/local/  --disable-xcb  --enable-glesv2 
$ make
$ make install
xkb files

Either

a) Copy from an existing system a set of xkb layouts

$ scp -r /usr/share/X11/xkb to /usr/local/share/X11/

or

b) build xkeyboard-config from git with --prefix=/usr/local and --disable-runtime-deps

weston
$ git clone git://anongit.freedesktop.org/wayland/weston
$ cd weston/
$ CFLAGS="-I/usr/local/include/libdrm/ -DMESA_EGL_NO_X11_HEADERS" ./autogen.sh --prefix=/usr/local/ --with-cairo-glesv2 --disable-xwayland --disable-x11-compositor --disable- xwayland-test
$ make
$ make install

See also

External links