Talk:Lenovo ThinkPad X1 Carbon

From ArchWiki
Jump to navigation Jump to search

UEFI support

I find it hard to believe that the latest Arch ISO still doesn't boot in UEFI for the X1 Carbon. Can anyone confirm? Is this specific to a particular Gen? Silverhammermba (talk) 16:38, 8 April 2016 (UTC)

I can confirm this. I tried with the newest version (archlinux-2016.05.01-dual.iso), which did not boot in UEFI, but does on another Laptop. Overseas (talk) 16:14, 15 May 2016 (UTC)

By forcing UEFI booting and disabling CSM support in the UEFI/BIOS settings i got it to work fine on my X1 gen3 Zenolijo (talk) 16:05, 22 May 2017 (UTC)

put (Gen 1) in the name?

I got quite confused looking up docs for my Gen 9 laptop, because the title of this article makes it sound like it covers all generations. Should we change the name to make it consistent with all the others? Oconnor663 (talk) 19:49, 3 August 2021 (UTC)

It seems to me that the proper name for this laptop is "Lenovo ThinkPad X1 Carbon", at least according to Wikipedia:ThinkPad X1 series#2012 - 1st generation, so that's one reason to leave the title as is. I think the note you added in the article's introduction should also be enough to clear up any potential confusion. However, it might be a good idea to add a similarly named redirect like Lenovo ThinkPad X1 Carbon (Gen 1), which might help when querying for "X1 Carbon Gen 1" in the wiki search. -- Flyingpig (talk) 20:16, 3 August 2021 (UTC)