Talk:Lenovo ThinkPad X1 Extreme (Gen 2)

From ArchWiki
Latest comment: 24 April 2021 by Ctag in topic Edit discussion


Both throttled and inter-undervolt attempt to undervolt the CPU. Without configuring throttled, it sets the undervolt to 0mv. If intel-undervolt is set to -150 they will thrash the setting back and forth.

Recommend using a single CPU power manager to set max watts and undervolt. Each tool is capable of both.

Pilotmatt (talk)pilotmattk Sun 01 Sep 2019 03:50:55 PM UTC

Sounds good to me, I've updated this section to hopefully clarify a bit more Sebirdman (talk)

Cannot get gigabit ethernet working

I only get 80 megabytes/sec up and down.

I know that it's not something hardware/connection related, because I can get gigabit ethernet on Windows (+ I've already checked to make sure the cables/switch are capable of gigabit). However, on Arch, I don't get gigabit ethernet. I've tried a bunch of ethtool commands from posts like:

$ ethtool -s enp0s31f6 autoneg off speed 1000 duplex full

but no luck. I'm pretty inexperienced with debugging this kind of thing. Any tips?

$ lspci -v | grep -A7 net
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)
	Subsystem: Lenovo Device 229f
	Flags: bus master, fast devsel, latency 0, IRQ 178, IOMMU group 15
	Memory at ce500000 (32-bit, non-prefetchable) [size=128K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Kernel driver in use: e1000e
	Kernel modules: e1000e

I don't see any relevant messages in dmesg either.

Arinerron (talk) 21:32, 15 December 2020 (UTC)Reply[reply]

Okay, I don't get it, but I added the kernel param @ and I started getting 4x the download speed and 1/2 the upload speed. The upload speed is concerning, but the tradeoff is worth it IMO.

Arinerron (talk) 21:56, 15 December 2020 (UTC)Reply[reply]

Suspend issues with kernel 5.2+

There currently seems to be an issue with suspend on kernels above version 5.2+ redhat bug. Recommend installing kernel 5.1.9 from the package archive and setting IgnorePkg = linux linux-headers in pacman.conf

Veridiam (talk) 16:14, 2 October 2019 (UTC)Reply[reply]

additional bug report here

Veridiam (talk) 05:19, 4 October 2019 (UTC)Reply[reply]

Brightness control issues

There should be a section mentioning brightness control issues. They do not seem to work out of the box when running discrete graphics only

Throttling fix

Package intel-ucode seems to be needed, otherwise for reasons that I don't understand, lenevo_fix can't load msr module:

sudo journalctl _SYSTEMD_UNIT=lenovo_fix.service[86444]: modprobe: FATAL: Module msr not found[86444]: [E] Unable to load the msr module.

Grossvater (talk) 09:36, 22 November 2019 (UTC)Reply[reply]

Keyboard loses keys

This is completely maddening and a bios issue on lenovo side that should be called out in the main wiki imo:

Any objections to linking there?

—This unsigned comment is by Sams (talk) 21:23, 8 January 2020 (UTC). Please sign your posts with ~~~~!Reply[reply]

Hi Sams, please sign talk comments with ~~~~ (from Help:Discussion). That's a long thread and I only skimmed it, but I didn't see any conclusive answers (some people said disabling USB powersaving didn't help). If there's a list of possible workarounds I think a section describing the problem and offering some things to try would make sense. Maybe with a different title though, "keyboard loses keys" immediately made me think of keys physically falling off. Ctag (talk) 13:14, 9 January 2020 (UTC)Reply[reply]
This issue seems to have been fixed by fw version 1.29 Sebirdman (talk) 05:08, 6 March 2020 (UTC)Reply[reply]

Touchpad/Trackpoint accuracy

The touchpad and trackpoint are "sticky" when doing small movements. This makes them feel much worse compared to windows or the touchpads of other notebooks.

Maybe this is related to the low refresh rate? The refresh rate measured with or is only ~80Hz compared to ~125Hz on Windows or with an external mouse. There was a patch to use RMI instead of smbus: , but it was later reverted as the buttons did not work. When I apply the patch manually, I can no longer reproduce the button issue, but I am unsure it is actually used. The refresh rate does not improve, though.

Keksdev (talk) 09:12, 22 January 2020 (UTC)Reply[reply]

Using the (deprecated) Touchpad Synaptics driver seems to partially alleviate the issue. Personally it still feels sluggish, but it seems like the "deadzone" when first moving the cursor is greatly reduced. Will have to test with different touchpad attributes to see how far this can be dealt with.
Niciuffo (talk) 20:05, 19 March 2020 (UTC)Reply[reply]

External display with PRIME

@ForeverZer0 Can you confirm that external displays now work with the driver? diff

Ctag (talk) 17:26, 28 May 2020 (UTC)Reply[reply]

Battery life improvements

I've noticed that some more tweaks are necessary to improve battery life. Adding `acpi_call` to the kernel modules helps as well as adding `acpi_osi=! "acpi_osi=Windows 2015"` to boot line. I would love it if someone could confirm these changes are valid, if so we can update the article. I'd also like to provide some tips regarding TLP and the charging thresholds. Another tip could be using powertop to change some things such as wake-on-lan and other configs that might help.

Mralpaca (talk) 15:56, 20 October 2020 (UTC)Reply[reply]

GPU Power Management

I couldn't get optimus-manager to work, but optimus-manager-git worked perfectly. On integrated mode, the power draw was still about 30W as the NVIDIA card is still on; and this can be fixed by running sudo modprobe nvidia "NVreg_DynamicPowerManagement=0x01" as per the NVIDIA power management instructions - this now has idle power usage on integrated mode at 8-9W. I haven't worked out how to make that change permanent yet - updating /etc/modprobe.d/nvidia.conf doesn't seem to do it. Rross101 (talk) 07:34, 30 October 2020 (UTC)Reply[reply]

Edit discussion

Why was so much information removed? There should be links to comparable sections if it's to be deleted. Ctag (talk) 01:01, 24 April 2021 (UTC)Reply[reply]