Talk:Matrix

From ArchWiki
Jump to navigation Jump to search

synapse account NOT created

I'll look into it, but having just downloaded and installed on an up-to-date ArchLinux box, I see:

Preparing...
Warning: postgresql: ignoring package upgrade (11.2-3 => 11.3-3)
Warning: postgresql-libs: ignoring package upgrade (11.2-3 => 11.3-3)
Resolving dependencies...
Checking inter-conflicts...

Downloading python-pynacl (1.3.0-1-x86_64)...
Downloading python-daemonize (2.5.0-1-any)...
Downloading python-bcrypt (3.1.6-1-x86_64)...
Downloading python-frozendict (1.2-3-any)...
Downloading python-pynacl (1.3.0-1-x86_64)...
Downloading python-frozendict (1.2-3-any)...
Downloading python-daemonize (2.5.0-1-any)...
Downloading python-bcrypt (3.1.6-1-x86_64)...
Downloading python-daemonize (2.5.0-1-any)...
Downloading python-bcrypt (3.1.6-1-x86_64)...
Downloading python-pynacl (1.3.0-1-x86_64)...
Downloading python-daemonize (2.5.0-1-any)...
Downloading python-bcrypt (3.1.6-1-x86_64)...
Downloading python-asn1crypto (0.24.0-2-any)...
Downloading python-cryptography (2.6.1-1-x86_64)...
Downloading python-pyopenssl (19.0.0-1-any)...
Downloading python-pyasn1 (0.4.5-1-any)...
Downloading python-pyasn1-modules (0.2.5-1-any)...
Downloading python-service-identity (18.1.0-1-any)...
Downloading python-systemd (234-2-x86_64)...
Downloading python-pymacaroons (0.13.0-3-any)...
Downloading python-pynacl (1.3.0-1-x86_64)...
Downloading python-daemonize (2.5.0-1-any)...
Downloading python-bcrypt (3.1.6-1-x86_64)...
Downloading python-frozendict (1.2-3-any)...
Downloading python-ujson (1.35-4-x86_64)...
Downloading python-pycryptodomex (3.7.3-1-x86_64)...
Downloading python-pysaml2 (4.6.5-1-any)...
Downloading python-unpaddedbase64 (1.1.0-3-any)...
Downloading python-simplejson (3.16.1-1-x86_64)...
Downloading python-canonicaljson (1.1.4-2-any)...
Downloading python-signedjson (1.0.0-4-any)...
Downloading python-phonenumbers (8.10.13-1-any)...
Downloading python-netaddr (0.7.19-2-any)...
Downloading python-sortedcontainers (2.1.0-2-any)...
Downloading python-treq (18.6.0-3-any)...
Downloading matrix-synapse (0.99.5-1-any)...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Installing python-asn1crypto (0.24.0-2)...
Installing python-cryptography (2.6.1-1)...
Installing python-pyopenssl (19.0.0-1)...
Installing python-pyasn1 (0.4.5-1)...
Installing python-pyasn1-modules (0.2.5-1)...
Installing python-service-identity (18.1.0-1)...
Installing python-pynacl (1.3.0-1)...
Installing python-daemonize (2.5.0-1)...
Installing python-bcrypt (3.1.6-1)...
Installing python-frozendict (1.2-3)...
Installing python-ujson (1.35-4)...
Installing python-pycryptodomex (3.7.3-1)...
Installing python-pysaml2 (4.6.5-1)...
Installing python-systemd (234-2)...
Installing python-unpaddedbase64 (1.1.0-3)...
Installing python-simplejson (3.16.1-1)...
Installing python-canonicaljson (1.1.4-2)...
Installing python-signedjson (1.0.0-4)...
Installing python-pymacaroons (0.13.0-3)...
Installing python-phonenumbers (8.10.13-1)...
Installing python-netaddr (0.7.19-2)...
Installing python-sortedcontainers (2.1.0-2)...
Installing python-treq (18.6.0-3)...
Installing matrix-synapse (0.99.5-1)...
Configuring matrix-synapse...
==> A synapse configuration file needs to be generated before you can
    start synapse, and you should make sure that it's readable by the
    synapse user.

    cd /var/lib/synapse
    sudo -u synapse python -m synapse.app.homeserver \
      --server-name my.domain.name \
      --config-path /etc/synapse/homeserver.yaml \
      --generate-config \
      --report-stats=yes

    N.B.: The default synapse config enables the webclient feature.
          You need to either disable it, install the syweb python package
          from matrix-angular-sdk, or set 'web_client_location' to a path
          to make synapse not try to serve it using syweb.

Running post-transaction hooks...
Reloading system manager configuration...
Creating system user accounts...
Error: command failed to execute correctly
Arming ConditionNeedsUpdate...
Transaction successfully finished.

Ubuntourist (talk) 13:08, 17 June 2019 (UTC)

Switching to Python 3

The latest version of Synapse (0.34.0, the one currently available in community) supports Python 3 (although python 3.7 is still experimental).

See their changelogs[1] and usage notes[2].

I think it would be ideal to start looking into migrating to Python 3.

Peoro (talk) 21:39, 6 January 2019 (UTC)

Python 3.7 about to become stable

According to some people on the #matrix:matrix.org chat room, Python 3.7 is supported on the development branch. They're about to release a new version soon just for that.

Peoro (talk) 21:58, 6 January 2019 (UTC)

Which is exactly what we need before migrating, since Arch is Python 3.7. ;) Archange (talk) 15:11, 7 January 2019 (UTC)
Synapse 0.34.1.1 was released, and Python 3.7 is now officially supported. Peoro (talk) 22:13, 10 January 2019 (UTC)
Special:Diff/562891 The community package now builds with Python 3. No especial efforts should be needed to migrate as far as this wiki page goes -- it would probably have made more sense as a bugtracker feature request, but we usually switch as soon as possible anyway. -- Eschwartz (talk) 23:34, 14 January 2019 (UTC)