Talk:TT-RSS

From ArchWiki
Jump to navigation Jump to search

Apache does not restart

I cannot restart apache after using a custom php.ini. The error is because of this step:

- Then add to your apache config:

<Location /tt-rss/>
      PHPINIDir /etc/webapps/tt-rss 
</Location>

The error is:

apachectl[24199]: Syntax error on line 536 of /etc/httpd/conf/httpd.conf:
apachectl[24199]: PHPINIDir not allowed here

I also read, that you cannot have more than one PHPINIDir. If you get it to work in your case (using a custom php.ini, as I cannot set open_basedir to none) I would like to know, how you did it.

Thx,(Watnuss (talk) 09:10, 7 May 2013 (UTC))


TT-RSS not working for me

First it was complaining that i didn't 'configure' it. I 'fixed' that by removing the symlink from /usr/share/webapps/tt-rss/config.php and putting the /etc/webapps/tt-rss/config.php file there. But now it's still complaining that cache/images, cache/upload, cache/export etc eetc are not writeable. I see those are also symlinks so I seem to have a problem with symlinks in general then? How is this supposed to work? Is it supposed to work with lighttpd?


ok it works now... i have setup the php basedir correctly (adding /usr/share/webapps/tt-rss, /var/lib/tt-rss and /etc/webapps/tt-rss) after that everything immediately worked.

process described is lacking

  1. doesn't specify that one needs to allow the postgres user to create databases
  2. doesn't specify the postgres user (though this is deducible from the next line)
  3. doesn't mention how to resolve when "php index.php" notes that open_base dir lacks the /etc config path
  4. doesn't mention how to resolve the permissions issue relating to config.php

--Milk (talk) 17:13, 11 March 2019 (UTC)