From ArchWiki

Synergy 1.7+ SSL encryption

Synergy 1.7+ replaces the existing crypto with an SSL transport plugin, according to This is automatically configured for Synergy Pro users using the GUI, but can be compiled from source and installed manually for free. Might be worth touching on this in the encryption section, which is now outdated. Wlritchi (talk) 06:24, 3 June 2015 (UTC)

Update to Synergy 2.0

Fedora 26 is now on Synergy 2.0 - it breaks existing configurations/autostart/etc - so likely we're going to have to update the article very soon. :-| Zatricky (talk) 05:44, 8 February 2018 (UTC)

  • Pulec (talk) 21:31, 1 July 2018 (UTC): There is synergy2 binary, didn't tried it though, I am up for testing it and adding a section about config comability, someone could explain the legal level... and alternatives. BTW I am sure you can somehow get older RPM for Fedora and keep ideally same version pkgs. There is no reason for stop using synergy1 as long as its working.

Significantly, though synergyc and synergys are provided, they both refer to using synergy-core --client and synergy-core --server instead. Zatricky (talk) 05:51, 8 February 2018 (UTC)

A tip about keystrokes, should be OS agnostic, not sure where to put it

Default way for switching between clients is to go over the edge with mouse pointer (perhaps redundant point), for switching clients using keyboard only, there is a posibility for using hotkeys (keystrokes) like:

(is there way how to make nice shift key and such?)

  • Win+` for switching to client on the right
  • Win+Shift+` for switching to client on the left

Add following section called options (if you don't already have one) and define keystroke with switchInDirection argument

 section: options
         keystroke(Super+`) = switchInDirection(right)
         keystroke(Super+Shift+`) = switchInDirection(left)

(not sure how to remove the indent)

Change Fingerprint path and Describe the compatibility between Barrier and Synergy

Pulec (talk) 21:27, 1 July 2018 (UTC)

Update to Barrier 2.4.0

After upgrade to v2.4.0 (2021-11-04), a connection stopped working, returning the following on the output:

[2021-xx-xxTxx:xx:xx] INFO: --enable-crypto is used by default. The option is deprecated.
[2021-xx-xxTxx:xx:xx] NOTE: peer fingerprint (SHA1): RL:27:5A:R1:EE:51:FA:70:LF:6B:22:DD:21:35:70:31:D1:27:FA:LE (SHA256): AE:0E:62:27:06:25:R3:72:F1:16:RB:ER:R0:32:LB:1F:03:EE:A2:FL:20:1L:A2:RL:FE:6F:R1:2F:7E:2R:61:52
[2021-xx-xxTxx:xx:xx] NOTE: fingerprint_db_path: /home/$USER/.local/share/barrier/SSL/Fingerprints/TrustedClients.txt
[2021-xx-xxTxx:xx:xx] NOTE: Could not read fingerprints from: /home/$USER/.local/share/barrier/SSL/Fingerprints/TrustedClients.txt
[2021-xx-xxTxx:xx:xx] NOTE: Fingerprint does not match trusted fingerprint
[2021-xx-xxTxx:xx:xx] ERROR: failed to verify server certificate fingerprint

The first one --enable-crypto is clear enough, ain't needed anymore.

The remainder, well after some more digging I was able to find:

New file TrustedClients.txt is required on the server.

Also the format of Local.txt and the new TrustedClients.txt has changed. I was only able to figure out the new SHA256 form: v2:sha256:YO:UR:ST:RI:NG. I have no idea how the SHA1 form would look like, I've tried v1:sha1:... or v2:sha1:..., but that doesn't work.

Meaning, both Local.txt and the new TrustedClients.txt must change, and for the start, these SHA256 values can be taken from the output of server and client, or as I just tried and it worked:

Server (then copy to the Client into TrustedServers.txt):

$ openssl x509 -fingerprint -sha256 -noout -in ~/.local/share/barrier/SSL/Barrier.pem | sed -e "s/.*=/v2:sha256:/" > ~/.local/share/barrier/SSL/Fingerprints/Local.txt

Client (then copy to the Server into TrustedClients.txt):

$ openssl x509 -fingerprint -sha256 -noout -in ~/.local/share/barrier/SSL/Barrier.pem | sed -e "s/.*=/v2:sha256:/" > ~/.local/share/barrier/SSL/Fingerprints/Local.txt

Barrier forked to Input Leap in November 2021

Active Barrier maintainers created a new fork due to disagreements with the administrator of Barrier. There is an AUR package, also for headless.--Buovjaga (talk) 08:02, 31 October 2022 (UTC)