Talk:Sony Vaio Pro SVP-1x21

From ArchWiki
Jump to navigation Jump to search

What's really going on with the usb ports?

It's totally dead for me and after some searching I found other users having the same issue. DOes it work for you? If so, what did you do to make it work? Kame (talk) 15:26, 4 September 2013 (UTC)

Works for me. Pepijndevos (talk) 11:54, 7 November 2013 (UTC)

UEFI hell

This laptop was definitely not Arch friendly to me. After installing several different linux distros, I had a very crowded EFI partition and a laptop that would boot straight to Windows whatever I tried. I finally got a working Gummiboot setup going, so I tried adding that info to this page. On the other hand, Native command queueing, Wifi and the Lighting-bolt-USB all worked flawlessly for me. Pepijndevos (talk) 12:58, 7 November 2013 (UTC)

I can confirm your observations, once successfully booted most hardware is working flawless, but its UEFI firmware crippled. Booting from both USB ports works for me, too. Thealchemist (talk) 10:56, 14 December 2014 (UTC)


Has anyone succeeded in getting Multitouch_Displays to work on this device? I tried installing xf86-input-egalaxAUR but I still only get single touch. Pepijndevos (talk) 20:03, 8 November 2013 (UTC)

I followed the wiki and everything is working with toucheggAUR. (Multitouch_Displays#Gestures) However, I could not get the touchpad multitouch gestures working with toucheggAUR 183.amir (talk) 13:05, 23 May 2014 (UTC)
xf86-input-egalaxAUR did not work for me, so I used xf86-input-elographics (works fine in GNOME). Thealchemist (talk) 10:56, 14 December 2014 (UTC)

Extension and rewrite

Hello, firstly I must admit that I am completely new to contributing to a Wiki, but now I feel the need to extend, update and correct this article with the experience I made with my SVP-1321-C5E. I think it would be sensible to list the things I observed. Maybe somebody can tell me, which information may be useful (or in which aspects might be based on wrong assumptions).


  • booting from both USB ports is fine
  • as far as I remember booting USB from security also works (I will check it again)


  • installing GRUB did not work for me (last try with Ubuntu 13.10 Ubiquity-installer)
  • efibootmgr does not function (modifications made do not affect boot process)
  • Windows 8 command line tool "bcdedit" DOES work flawless


  • 3.12 kernel is now LTS (update comment)


  • the described way of switching sound cards does not help.
  • I HAVE some trouble with sound and did not find a real fix (specifically switching sound device in GNOME to HDMI to watch videos in firefox works fine. but pulling out the video cable leads to a no-sound-issue in firefox. It can be fixed by removing ~/.config/pulse/* or sound device with HDMI cable put in again.)


Ah, and last but not least you may have catched me - I am not a native speaker. So corräct pleas my mistaiks! Thealchemist (talk) 10:56, 14 December 2014 (UTC)

I'm afraid the discussion will not be checked as frequently as a forum and as the VAIO Pro aged for more than a year the interest is depleted a little... so I decided to start editing. Anybody angry with me can speak. Thealchemist (talk) 08:26, 15 December 2014 (UTC)

Toggle TouchPad via Fn+F1

I have a SVP1321. The procedure described in the wiki for toggling the touchpad via Fn+F1 did not work for me and needed some little tweaks.

I modified the first line of /etc/acpi/events/toggle-touchpad from

event=button.fnf1 FNF1


event=button/fnf1 FNF1 00000080

As described Here

This did the trick for me.

Don't forget to restart the ACPI daemon:

sudo /etc/init.d/acpid reload

Hope it helps.

--Aleeraser (talk) 18:29, 28 January 2016 (UTC)