Talk:Webcam setup

From ArchWiki
Jump to: navigation, search

v4l2

The VLC section recommends v4l:// to view and record from the webcam. This produces errors unless v4l2:// is used. http://en.wikipedia.org/wiki/Video4Linux says V4L1 support was dropped in kernel 2.6.38. Should this be changed or additional information included to the wiki? Corburn 16:02, 5 March 2012 (EST)

Definitely, please just update the article, there's no need to keep outdated information. If you want you can also spend a few words about the deprecation of v4l in favour of v4l2. -- Kynikos 05:19, 6 March 2012 (EST)

Image preprocessing

Any programs with configuration to make a dark image/detect broken pixels and set up preprocessing to help against it?(preferably in the configuration) I guess it is a bit of an 'advanced' feature.

Note: xawtv still freezes the system for me even after adding /etc/modprobe.d/uvcvideo.conf (Other programs work)Jasper1984 (talk) 13:41, 18 September 2012 (UTC)

Module loading

"If your webcam is USB, the kernel should automatically load the proper driver."

I have a Thinkpad X230 with an integrated webcam (USB-ID 5986:02d2) which seems to work with the uvcvideo module. The drivers were not automatically loaded though. I first thought the device might be unsupported because I couldn't find this exact USB ID in the list of supported UVC webcam devices, or anywhere else.

As the uvcvideo module seems to support a lot of common devices(?), should there be a generic hint like "if it isn't automatically loaded, try modprobe uvcvideo" in this article, or is this too much trial-and-error?

Another idea would be to mention this in Lenovo_ThinkPad_X230, but as there might be other devices using this webcam this might not be the right place either...

Any opinions?

binaryDiv (talk) 18:01, 8 October 2018 (UTC)

Did modprobe uvcvideo actually work or did you have to reboot as well? -- Lahwaacz (talk) 18:10, 11 October 2018 (UTC)
Reboot after doing what...? I'm using this system for a while now and always thought it didn't have a webcam because it wasn't auto-detected (and I didn't need it anyway). Now I tried modprobe uvcvideo and it worked, I didn't do anything before that. binaryDiv (talk) 13:55, 12 October 2018 (UTC)
E.g. after a kernel upgrade... Lahwaacz (talk) 19:49, 12 October 2018 (UTC)