Talk:DaVinci Resolve

From ArchWiki
Latest comment: 16 April by RokeJulianLockhart in topic noborderrule=2 doesn't work on Wayland.

Python 3.6 not found problem

I need help with setting python 3.6 that way that:

  • I can install packages there (with pip?)
  • dr could see the python 3.6
  • pycharm could debug scripts in that installation

The problem of not seen python 3.6 is discussed here:

I set External scripting using to Local in General settings. Installed python36 (tried both from aur and with pyenv). Then with variables RESOLVE_SCRIPT_API, RESOLVE_SCRIPT_LIB and PYTHONPATH and with /usr/bin/python3.6 interpreter, I successfully run the example script (it creates the Hello World project). Place it to the ~/.local/share/DaVinciResolve/Fusion/Scripts/Utility/ It appears in Workspace -> Scripts.

If I go to Workspace -> Console -> Py3, I now see there is no more error window that python 3.6 it is not found.

I tried with patched (see [1]) python36AUR and it was detected by dr. But now I am thinking that it is better with virtual environment, because I need other python libs available for scripting, and aur python packages only supposed for latest python version.

Help will be appreciated.

Ashark (talk) 04:40, 7 February 2022 (UTC)Reply[reply]

Docker and DR

I have found a project for dr containerization. I did not explored it yet, which benefits it gives versus normal pkgbuild repackaging. And it seems it is targetet for ubuntu and for nvidia. Probably, it may be useful somewhen, so I decided to keep it here for this link not being lost.Ashark (talk) 11:14, 6 April 2022 (UTC)Reply[reply]

Workaround for DR Free causes a/v desync

$ ffmpeg -i input.mp4 -c:v dnxhd -profile:v dnxhr_hq -pix_fmt yuv422p -c:a pcm_s16le -f mov

This causes a/v desync to me (15 min video, generated with vlog-toolset).

In case if anybody runs into the same issue, here's the solution:

$ ffmpeg -threads 16 -fflags '+genpts+igndts' -i input.mp4 -c:v dnxhd -profile:v dnxhr_hq -pix_fmt yuv422p -af 'aresample=async=1,asetpts=PTS-STARTPTS' -c:a pcm_s16le -f mov

The downside is that it makes sound in DaVinci Resolve preview choppy, but it's fine after final rendering. Alopatindev (talk) 00:21, 4 March 2024 (UTC)Reply[reply]

noborderrule=2 doesn't work on Wayland.

As explains, noborderrule=2 shan't work on Wayland, per the decision at Is there a better solution available? Regardless, we should probably add something to mention this caveat.

When using a forum, remember to tag the person you are responding to, in case they are not subscribed to the thread. (talk) 16:39, 16 April 2024 (UTC)Reply[reply]