From ArchWiki

I think there's an error in this page, maybe related to a davfs bug. I followed the instructions to mount a webdav resource as a regular user, but when I tried to mount it I got the following error: "Could not authenticate to server: rejected Basic challenge". Following these instructions didn't helped: I noticed that deleting the secrets file in my home directory and manually providing the credentials in the shell worked. I then read the mount.davfs manpage and found this: "WARNING: If root allows an ordinary user to mount a file system (using fstab) this includes the permission to read the associated credentials from /etc/davfs2/secrets as well as the private key of the associated client certificate and the mounting user may get access to this information. You should only do this, if you might as well give this information to the user directly". So I placed my credentials in /etc/davfs2/secrets instead of ~/.davfs2/secrets and everything worked as expected. I think this page shold be edited accordingly or at least provide this fix in the "Troubleshooting" paragraph.

I found another problem: on my laptop using the mount utility as described here to mount webdav resources doesn't work (gives a "SSL handshake failed: SSL error: wrong version number" error) but using the mount.davfs utility works without any problem, despite the fact that this page explicitly tells not to use it to manually mount resources. Please update this page and explain why mount.davfs shouldn't be used or drop that line since it's misleading.

Start a discussion about Davfs2

Start a discussion