Talk:Dell XPS 13 (9300)

From ArchWiki
Latest comment: 21 July 2020 by DasJott in topic Sound and WiFi

Sound and WiFi

I am using Manjaro Linux on my machine and the recent update made my sound and WiFi completely vanish. For playback there is only a dummy device left and WiFi module is loaded but doesn't work at all. Maybe that's worth a hint for others... DasJott (talk) 07:22, 21 July 2020 (UTC)Reply[reply]

Power Management

I personally have an issue where after waking up from deep sleep (s2ram) the touchscreen will stop working until the next reboot. I currently have no solution for this. Touchscreen resume fine if using s2idle (default sleep). Cottand (talk) 18:45, 17 April 2020 (UTC)Reply[reply]

In terms of power draw during sleep, I don't notice any meaningful percentage loss when the laptop is in s2idle over a long period (like 10 hours overnight). This was on BIOS 1.0.6, just updated to .7 which I hope does not make it worse! Resuming from deep sleep does not work at all for me. It just gets stuck on the Dell logo. Jdiez (talk) 16:41, 19 April 2020 (UTC)Reply[reply]

You need to disable a 'sign of life' option in the BIOS for the wakeup to work. Sorry I added it a bit late to the page! Cottand (talk)
Thanks! That worked. Jdiez (talk) 13:08, 1 May 2020 (UTC)Reply[reply]

Guys, who is using this laptop with a TB19 dock? It is very flaky for me. E.g. always locks up when resuming from suspend (s2idle or deep) with dock attached. Bulletmark

Try booting up with intel_iommu=igfx_off or, more radical, intel_iommu=off Kubrick (talk) 06:18, 23 June 2020 (UTC)Reply[reply]
Already tried both of those with no difference. Do you have this dock and does it work fine for you? Bulletmark
I have the TB16, and it have different issues with it :-D I have reached out to Dell business support and they say they are working on the various dock compatibility issues but no precise list of issues or ETA of course. Kubrick (talk) 07:25, 23 June 2020 (UTC)Reply[reply]
I have the Caldigit TS3+ and the monitor connected via USB-C couldn't set the resolution correctly, the Dell support told me that the engineering team has a bios release planned in November to address the dock compatibility issues. Mark42

Touch screen

Not strictly related to XPS 13 9300 but the touchscreen works with the default kernel, but not with a compiled one. Tried `lsmod` for the default versus the compiled. All the modules are available in the compiled one as well. Is there a parameter or something else I am missing?