Talk:Dell XPS 13 (9310)

From ArchWiki
Latest comment: 1 May by IUSR in topic Bluetooth

Video drivers

Following what is mentioned in Intel graphics#Installation I initially refrained from installing the xf86-video-intel package. This resulted in some weird jittery behaviour in the rendering of text. For example, when attempting to type "" in a browser address field the text rendering would suddenly jump back by 1/2 strokes (I'm typing "ch", the "c" appears shortly but the screen immediately refreshes to only show "wiki.a") and refuse to update for maybe a second. It would then catch up if I kept typing. I was able to fix this by installing the Intel drivers instead of relying on the modesetting driver. Is anyone having similar issues and/or is it known that something like that happens with 11th Gen Intel CPUs?

Avernan (talk) 17:04, 30 December 2020 (UTC)Reply[reply]

I'm getting some lagging all around gnome-shell. Mouse suddenly stops for a sec or two every now and then. Same when typing. Actually, the whole UI freezes not only input. Will try installing intel's driver as suggested and see what happens. Will reply back soon.

Migralito (talk) 18:34, 19 April 2021 (UTC)Reply[reply]

This is a visual hitch caused by Panel Self Refresh.

Fix: uninstall xf86-video-intel, add "i915.enable_psr=0" to kernel parameters (using i915 kernel driver)

I have added this to the known issues section

Amazingefren (talk) 10:25, 7 May 2021 (UTC)Reply[reply]

WiFi working or not?

Hi, after upgrade to system firmware 1.2.5 I apparently can use the system wifi adapter with stock kernel even though it was absent in `iwctl` on previous firmware versions. Can anyone else confirm if it's working on their end too?

I do have 32 GB version of 9310:

$ networkctl status wlan0
● 4: wlan0
     Link File: /usr/lib/systemd/network/
  Network File: /etc/systemd/network/
          Type: wlan
         State: routable (configured)
          Path: pci-0000:72:00.0
        Driver: ath11k_pci
        Vendor: Qualcomm

Wiktor (talk) 09:25, 28 January 2021 (UTC)Reply[reply]

+1 for a kinda sorta working WiFi with a stock kernel, though that only happened for me with the release of the 5.10.9 kernel - the firmware upgrade didn't help. I was still getting slightly better stability with a patched kernel (I made the patch myself but used the arch kernel build to apply it), but some stuff is still fairly broken, like recovering from hibernate and the like. Sometimes I need to `rmmod` the `ath11k_pci` module, and it can take a couple of minutes, and then reload it. Sometimes attempting to do that dumps core.

So yes, we seem to be converging on a working laptop :)

J0ni (talk) 10:16, 26 January 2021 (UTC)Reply[reply]

Thanks for the feedback J0ni! I don't use hibernation and haven't seen the issue so glad that you've commented.

I'm not so well-versed in Arch Wiki rules but maybe it'd be a good idea to update the 9310 page to note that WiFi is working with new firmware and recent kernel out of the box (with issues that you've mentioned)?

Wiktor (talk) 09:25, 28 January 2021 (UTC)Reply[reply]

I'm not so well versed either, but I think an edit is in order most likely. I wouldn't say it's stable - as I've lived with stock kernels (and actually the `ath11k-qca6390-bringup` patch I made, I've found that both suspending and hibernating cause the network to die in a way that requires me to unload and reload the `ath11k_pci` kernel module, and usually restart the `NetworkManager` service. Something similar is likely required for people depending on `systemd-networkd` but I guess that's less common with laptop users.

I'll make an edit and see how people feel about it. Feel free to tweak it if my words don't generalize to your experience Wiktor.

J0ni (talk) 07:27, 29 January 2021 (UTC)Reply[reply]

Great! Thanks J0ni! I've added a note about firmware as only starting from this combination of firmware + kernel version worked for me.

For the record I'm actually using `systemd-networkd` on a laptop (managing networks with `iwctl`). It's nice :)

Wiktor (talk) 08:06, 29 January 2021 (UTC)Reply[reply]

Hello all - I still needed the kernel parameter memmap to get the card to work on a fresh install with 5.12 (after first updating firmware from dell), wondering if anyone can confirm? Also, adding the memmap=12M\$20M to /etc/default/grub is a bit tricky because the backslash is parsed by something before it ends up in the kernel options at runtime (grub-mkconfig maybe?). Fixed by using single-quotes like so: GRUB_CMDLINE_LINUX='memmap=12M\$20M'. Should this be included in the wiki as a tip?

AdlaiN (talk) 07:24, 8 May 2021 (UTC)Reply[reply]

So, first time I tried a fresh Arch install with the stock kernel, WiFi didn't work, same with 5.12 from [testing]. Seems there's a bug with Arch's kernel Pop!_OS which comes with 5.11, WiFi and suspend work out of the box.

Maevius (talk) 10:37, 8 May 2021 (UTC)Reply[reply]

Another update on the wifi: I've been having persistent problems with the firmware crashing randomly, (ath11k_pci ... firmware crashed: MHI_CB_SYS_ERROR) and what seems to have helped is to increase the reserved memory (I changed from 20M to 40M). Just in case this is helpful.

AdlaiN (talk) 03:28, 24 May 2021 (UTC)Reply[reply]

Just kidding, increasing the reserved memory did not help. The firmware crashes some minutes after booting.

AdlaiN (talk) 03:44, 24 May 2021 (UTC)Reply[reply]

Hi all, I have recently upgraded to kernel 5.13.0-rc3, and the wifi has been stable: no firmware crashes; suspend and resume work correclty without unloading/loading kernel module hooks with systemd; and no memmap=12M\$20M in kernel paramter.

I encourage everyone to try this out and remove all the previous hacks. If no issues found, we can move AX500 status to "working" when the 5.13 kernel releases. :)

Mark42 (talk) 06:07, 7 June 2021 (UTC)Reply[reply]

Hi all, I got a XPS 9310 32Gb RAM with the QCA6390 (AX500) wireless adapter.

Wifi has been at worst not working, at best unstable with different kernels i've tested so far:

  • linux 5.12.12.arch1-1
  • linux-lts 5.10.46-1
  • linux custom 5.13.0-rc7 modprobing after restoring -
  • linux custom 5.13.0-rc3 <= most stable but still I suffer slow downs, plus i hook suspend/resume to manually rmmod and modprobe the ath11k_pci module.

GRUB_CMDLINE_LINUX='memmap=12M\$20M' is set into /etc/default/grub

Here is my current config.

$ networkctl status wlp114s0
 ● 2: wlp114s0
                    Link File: /usr/lib/systemd/network/
                 Network File: n/a
                         Type: wlan
                        State: routable (unmanaged)
                         Path: pci-0000:72:00.0
                       Driver: ath11k_pci
                       Vendor: Qualcomm
                        Model: QCA6390 Wireless Network Adapter [AX500-DBS (2x2)]
                   HW Address: 9c:b6:d0:3f:50:f0 (Rivet Networks)
                          MTU: 1500 (min: 256, max: 2304)
                        QDisc: mq
 IPv6 Address Generation Mode: none
            WiFi access point: TP-Link_AP_6D00 (1c:24:cd:3f:7e:e9)
         Queue Length (Tx/Rx): 4/1
                      Gateway: (Askey Computer Corp.)
                               fe80::1e24:cdff:fe3f:7ee0 (Askey Computer Corp.)
            Activation Policy: up
$ yay -Qs linux-firmware
 local/linux-firmware 20210511.7685cf4-1
$ uname -a
Linux sifumobile 5.13.0-rc3 #1 SMP PREEMPT Fri Jun 25 08:21:10 CEST 2021 x86_64 GNU/Linux

FdLSifu (talk) 14:22, 25 June 2021 (UTC)Reply[reply]

Hmm, FdLSifu can you expand on the issues you're running into? Looks like I've got the same computer as you and haven't had any issues with Wifi (I still haven't figured out Bluetooth) once I set up the recommended sleep hooks. I'm on 5.13.5-arch1-1.

Ocelotsloth (talk) 03:35, 30 July 2021 (UTC)Reply[reply]

I've tested Ubuntu 20.04 with oem firmware. I had some hanging issues when I woke up from suspend but everything else worked well. I reinstall archlinux because this is my target! On 5.13.5-arch1-1, Wifi works very well indeed. What is the sleep trick ? On some boots, bluetooth may or may not work. To make it work I have to completly turn off the laptop (reboot won't make it work). This is based on my experience ...

FdLSifu (talk) 13:48, 31 July 2021 (UTC)Reply[reply]

Why are we saying "Since Kernel version 5.14 (apart from broken wifi in 5.14.5 and 5.14.6, regression bug) wifi works fine, no issues with 5GHz and WPA3. No additional systemd kernel module removal scripts are required anymore, the Kernel suspends and resumes correctly." and stating that AX500 is stable? I'm on 5.14.9 and the card is broken when resuming from hibernation (which is the only viable sleep option for this laptop).

GrzegorzKozub (talk) 15:08, 7 October 2021 (UTC)Reply[reply]

I'm not having much luck with the sleep hooks. When I hibernate and restore, the wifi adapter isn't available. I've tried:

  • manually removing the module before hibernating and manually modprobing it after resuming - this works
  • using both hooks - doesn't work
  • using just the suspend hook, and manually modprobing after resuming - doesn't work
  • manually removing the module, and having the resume hook modprobing after resume - does work

Has anyone else seen this or do these hooks work for everyone else?

using the stock kernel and up to date bios.

Gsej (talk) 15:05, 19 October 2021 (UTC)Reply[reply]

I just set up hibernation to test this (I've been using suspend with little issue....battery life isn't even an issue and I don't even need suspend/resume hooks for wireless) and can confirm the issue described by Gsej. I set up the following hooks:

Description=Suspend: rmmod ath11k_pci

ExecStart=/usr/bin/rmmod ath11k_pci



Description=Resume: modprobe ath11k_pci

ExecStart=/usr/bin/modprobe ath11k_pci


I can verify that, after enabling the units, these are run before and after hibernation. Wireless still does not work. Additionally, once the wireless is broken in this way I can no longer resume from suspend (suspend, not hibernation). When I suspend and resume in this impaired state the laptop will show no signs of life other than the caps lock key flashing on and off a couple times a second.

I'm on 5.14.14-arch1-1 and system firmware version 3.0.4. If it matters I'm using full disk encryption (lvm) with encrypted boot partition and swap.

For now I'm just going to go back to using suspend and disable hibernation. I don't have any battery life issues on suspend. I just opened my laptop after two weeks of being suspended and still have 30 percent battery life. I guess I'm not sure if that's *good*, but it's definitely good enough.

Ocelotsloth (talk) 02:09, 30 October 2021 (UTC)Reply[reply]

My wifi worked before (at least on kernels 5.14 and 5.15, maybe also 5.10), but "suddenly" stopped working. Turns out it didn't happen by itself: I disabled `VT for Direct I/O` in the BIOS. After that, `lspci -k` did show `QCA6390`, but neither `rfkill` nor `ip link` showed the wifi adapter. Re-enabling `VT for Direct I/O` fixed that and now wifi works again. What do you think about adding that sidenote to the first line of [AX500](

Hrm (talk) 07:31, 9 January 2022 (UTC)Reply[reply]

I am still getting unpredictable firmware crashes on kernel 5.16.4, unrelated to suspending the laptop: ath11k_pci 0000:72:00.0: firmware crashed: MHI_CB_SYS_ERROR. Sometimes removing and reinserting the module will fix things, other times a reboot is required.

AdlaiN (talk) 04:58, 4 February 2022 (UTC)Reply[reply]

sukosevato (talk) 13:32, 24 May 2022 (UTC)Reply[reply]

I can confirm what Hrm is stating that the AX500 is quite unstable. It works most of the time. Also when waking up the laptop. But during normal usage it randomly starts dropping packets. Reloading ath11k_pci via modprobe might solve it, it might also completely hang the laptop requiring a reboot.

Right now I'm running 5.17.7-arch1-1 with linux-firmware 20220509.b19cbdc-1 and just now had wifi die on me where the laptop started freezing. Turning off wifi and continuing via wired connection solves the problems (or rebooting most likely). I've had these stability issues on all previous kernels (since September 2021) to some extend. So I'd definitely not call it stable either.


It's listed as working with no comments, but is it? It can't scan for other devices, nor is it visible to them, and I think it breaks suspend too but I haven't given it enough troubleshooting yet.

`dmesg` (several screens' worth of this):

[   96.649876] Bluetooth: hci0: Frame reassembly failed (-84)
[   96.665987] Bluetooth: hci0: Frame reassembly failed (-84)
[   96.665997] Bluetooth: hci0: Frame reassembly failed (-84)
[   96.681939] Bluetooth: hci0: Frame reassembly failed (-84)
[   96.681949] Bluetooth: hci0: Frame reassembly failed (-84)
[   96.697965] Bluetooth: hci0: Frame reassembly failed (-84)


[bluetooth]# power off
Changing power off succeeded
[bluetooth]# power on
Failed to set power on: org.bluez.Error.Failed
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# scan on
Failed to start discovery: org.bluez.Error.NotReady

Restarting `bluetooth.service` doesn't seem to fix things. `rfkill` shows it as being unblocked. Tested on 5.11 from repos and 5.12-rc1 built from git.

Zorael (talk) 17:08, 5 March 2021 (UTC)Reply[reply]

I've been using the stock kernel for more than a year without major issues with Bluetooth; the problems are no hibernate and restart, only suspend and cold restarts, which are not too bad for me. Sadly, it seems even this is now broken since kernel 6.8.7, and I have to stick with 6.8.6.
What are your mileages concerning Bluetooth? I'd hate to have a dongle for Bluetooth, no matter how small it is. IUSR (talk) 04:24, 1 May 2024 (UTC)Reply[reply]

I'm not seeing this in Fedora Rawhide (5.12.0). I have two Bluetooth devices that I switch between two computers so I have devices coming and going with no problems.

It may be that suspend/resume could cause problems, my 9310 is connected to wall power almost all the time.

Pfps (talk) 17:50, 5 March 2021 (UTC)Reply[reply]

I updated to 5.12-rc.2+ and had one boot where bluetooth was working, but after a reboot it no longer does and I cannot get it to return no matter what I try.

Suspend works with this script, saved as `/usr/lib/systemd/system-sleep/bluetooth-fix`:



case $1 in
        echo "$DEV" > ${SYS_NODE}/unbind
        echo "$DEV" > ${SYS_NODE}/bind

`dmesg` when it reenables:

[  166.693182] hci_uart_qca serial0-0: failed to acquire enable gpio
[  166.693697] Bluetooth: hci0: setting up ROME/QCA6390
[  169.047046] Bluetooth: hci0: command 0xfc00 tx timeout
[  177.153735] Bluetooth: hci0: Reading QCA version information failed (-110)
[  177.153744] Bluetooth: hci0: Retry BT power ON:0
[  179.500388] Bluetooth: hci0: command 0xfc00 tx timeout
[  187.610267] Bluetooth: hci0: Reading QCA version information failed (-110)
[  187.610278] Bluetooth: hci0: Retry BT power ON:1
[  190.170241] Bluetooth: hci0: command 0xfc00 tx timeout
[  198.060358] Bluetooth: hci0: Reading QCA version information failed (-110)
[  198.060369] Bluetooth: hci0: Retry BT power ON:2
[  200.410234] Bluetooth: hci0: command 0xfc00 tx timeout
[  208.513600] Bluetooth: hci0: Reading QCA version information failed (-110)

Zorael (talk) 10:43, 8 March 2021 (UTC)Reply[reply]

Bluetooth pretty borked on 5.15.10. The bluetooth firmware randomly prevents suspend: kernel: Bluetooth: hci0: SSR or FW download time out kernel: PM: dpm_run_callback(): acpi_subsys_suspend+0x0/0x60 returns -110 kernel: hci_uart_qca serial0-0: PM: failed to suspend: error -110 kernel: PM: Some devices failed to suspend, or early wake event detected One can remove `rmmod hci_uart` and suspend normally; reboot also temporarily fixes the problem. That said this is an improvement, bluetooth used to freeze up the CPUs on this machine.

AdlaiN (talk) 09:08, 20 December 2021 (UTC)Reply[reply]

Back to freezing up my laptop when hci_uart is loaded - get this in dmesg on multiple cores until the machine stops responding to input or I unload hci_uart. watchdog: BUG: soft lockup - CPU#2 stuck for 26s! [swapper/2:0]

AdlaiN (talk) 11:59, 24 January 2022 (UTC)Reply[reply]

Bluetooth is still not working properly in 6.2:

[   35.871848] hci_uart_qca serial0-0: failed to acquire enable gpio
[   35.872325] Bluetooth: hci0: setting up ROME/QCA6390
[   35.938818] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   35.938821] Bluetooth: BNEP filters: protocol multicast
[   35.938824] Bluetooth: BNEP socket layer initialized
[   38.362814] Bluetooth: hci0: command 0xfc00 tx timeout
[   39.592937] kauditd_printk_skb: 15 callbacks suppressed
[   46.255971] Bluetooth: hci0: Reading QCA version information failed (-110)
[   46.255985] Bluetooth: hci0: Retry BT power ON:0
[   48.602588] Bluetooth: hci0: command 0xfc00 tx timeout
[   56.709189] Bluetooth: hci0: Reading QCA version information failed (-110)
[   56.709205] Bluetooth: hci0: Retry BT power ON:1
[   59.055823] Bluetooth: hci0: command 0xfc00 tx timeout

On the odd occasion it does work, using it with bluetooth headphones will work for a few minutes until the audio starts to get corrupt and other errors start to appear in dmesg (don't have them handy).

Russkel (talk) 01:39, 7 April 2023 (UTC)Reply[reply]


Confirm as not working? It's a USB device on the 9360 but Windows device manager suggests it's i2c on the 9310. Does not show up in `xinput list` regardless.

Zorael (talk) 16:14, 14 March 2021 (UTC)Reply[reply]

It stops working since Linux 5.12, previous kernels work fine to me. Which kernel are you using?
Mark42 (talk) 05:54, 15 March 2021 (UTC)Reply[reply]
That is... unfortunate. Yes, I'm on 5.12-rc.3, to have wifi working.
Zorael (talk) 15:24, 17 March 2021 (UTC)Reply[reply]
This is due to a config option changed in 5.12. The config file from linux-mainline AUR is outdated, adding CONFIG_I2C_HID_ACPI=m should bring back the touch screen driver.
Mark42 (talk) 18:38, 20 April 2021 (UTC)Reply[reply]
No problems for me on a fresh install with 5.12.9
AdlaiN (talk) 23:42, 13 June 2021 (UTC)Reply[reply]

Power Management

Unclear if we have support for suspend-to-RAM, can someone confirm? By default systemd suspend state is s2idle (a screen blank, as far as I can tell). The kernel interface does not appear to support anything but s2idle ("shallow" or "deep" suspend).

% cat /sys/power/mem_sleep 

There is a BIOS option to block S3 suspend, but it is toggled off by default. Would appreciate if anyone can talk a little about their suspend/hibernate experience with the 9310 - it seems this is a common issue for new laptops there's a long discussion here for a different laptop:

AdlaiN (talk) 20:14, 5 June 2021 (UTC)Reply[reply]

It seems like we do not have support for suspend-to-RAM. I'm having trouble finding a primary source, but if this AskUbuntu source ( is to be believed:

  • s2idle is all that's supported in Linux.
  • Initially there was a power fix in the Ubuntu OEM kernel that was contributed upstream in 5.10.

From my personal experience I haven't had any trouble with s2idle, I'm currently on 5.12.15-arch1-1. I'll see if I can get proper measurements of the power drain in s2idle.

Ocelotsloth (talk) 05:38, 17 July 2021 (UTC)Reply[reply]

Webcam too dark

Hello, is anyone else's webcam way too dark? I installed v4l2ucp to try and tweak the image, but it's still pretty garbage.

An2quo (talk) 18:11, 9 December 2021 (UTC)Reply[reply]

I do not have this issue. Any chance it's in IR mode? Try hitting the switch camera button on your application to see if that's it.
Ocelotsloth (talk) 18:16, 9 December 2021 (UTC)Reply[reply]
Good suggestion. I double checked the camera, but it seems like it's the normal video camera. I posted in the forum with photo samples here:
An2quo (talk) 20:13, 13 December 2021 (UTC)Reply[reply]

Seems like there are other folks experiencing the same issue over at the Dell Support forums.