Talk:HP Spectre x360 13-ap0xxxx

From ArchWiki
Latest comment: 19 November 2020 by Rhysperry111 in topic Audio

Disabling Secure Boot

I've just setup HP ProBook 470 G5 with 2018.12 (will create a page on it later) image and also had trouble disabling secure boot. In my case I'd change the dropdown in BIOS to "Legacy Boot Disable and Secure Boot Disable" (which in HP-speak means "enable UEFI non-Secure Boot" I think) but it won't save the settings upon exit with no messages or any helpful information. With trial and error I had to uncheck the "Fast Boot" option and make sure Windows is fully shut down with shutdown /s /t 0. After it prompted for the pin on reboot, secure boot was off and I was able to boot from Arch ISO USB in UEFI mode. I hope your HP BIOS is similar enough for this to work as well. Romstor (talk) 17:26, 19 December 2018 (UTC)Reply

It is not needed for the spectre. Just disabling secure boot works out of the box in the box, but somehow you also need to enable legacy boot, even if you don't use it. I have yet to check if I can now boot with
legacy boot disabled. Gled (talk) 18:50, 19 December 2018 (UTC)Reply

The pen

The pen disables the touchscreen intentionally, so to avoid that it reacts to your hand touching the screen when using the pen. It is a feature, not a problem.

The default keymap for pen's button are wrong. I have made a simple python console tool which map BTN-BOTTOM to left mouse. You can find it in Pypi repository - see hps360pen for how to use. User:GusBite (talk).


I am currently on kernel 5.4.24-1, but the mic is not working for me. It would be helpful to mention which "old modules" exactly need to be blacklisted. I have tried

blacklist snd-hda-intel and blacklist snd-soc-skl

in /etc/modprobe.d/blacklist.conf, but then my sound card is not detected at all anymore. Any would be appreciated.

I can confirm this on the x360-15: with blacklisting `snd_hda_intel` and hence using `snd_sof` (`linux=5.5.11-arch1-1`), only "Dummy output" is listed and still no input. Mschu (talk) 10:23, 27 March 2020 (UTC)Reply
I just updated the audio section to explain what worked for me


In this article you said the mute LED does not work. I had a similar issue on my HP Pavilion cx-0598na, and found the solution to the problem was setting some module parameters. I made note of this on the main Laptop page. Could you please test if this works and update this page if you manage to fix it?

Rhysperry111 (talk) 17:32, 19 November 2020 (UTC)Reply