Talk:Install Arch Linux with Fake RAID

From ArchWiki

Grub without chroot?

Could GRUB be installed without chroot? Probably easier to do a pacman -U /pathToPackages/grub* followed by grub-install /dev/mapper/raidSet and skip chroot and the graphical bootloader installation. -- Loosec

Determine number of root devices

I was getting the "major/minor" error, as detailed at the end of the page. Should be noted (I pulled a fair bit of hair out until I figured this out) that you need to use pacman to install dmraid before you can include it as a mkinitcpio hook, so that it can work. Patyeon 17:50, 14 August 2011 (EDT)

You are free to try and add it yourself, don't be scared of the wiki :) -- Kynikos 06:02, 15 August 2011 (EDT)

Out of date page? (use mdadm instead of dmraid)

Intel RST (Rapid Storage Technology) recommends using mdadm rather than dmraid for fake raid.

My Intel (ISW) raid would get detected by dmraid but fails to detect my partitions. After installation of Arch and rebooting it would not even detect anything anymore. Seems like many user on all kind of Linux distributions have their problems with dmraid. HOWEVER, mdadm works perfectly fine. My raid now shows up at /dev/md126 and /dev/md127 or /dev/md/<NAME>_0 and it' partitions at /dev/md/<NAME>_0p1 ...
Not sure why not to use mdadm. My system now has access to it's raid via Linux and Windows.
Thought I might write this down, in case someone has problems with dmraid, that mdadm might be the answer he is looking for.
So set USEDMRAID to "no" in your /etc/rc.conf, reboot and look out for /dev/md*.--Spezifanta (talk) 10:32, 5 June 2012 (UTC)Reply[reply]
I can confirm. My partitions aren't detected too from 2013.07 installation media and onwards. dmraid was working fine before 2013.07 though. Will check the recommendations from Intel and will update this guide. I'll flag the installation part as out to date. Wget (talk) 21:42, 8 August 2013 (UTC)Reply[reply]
Well now solved. The dmraid module wasn't loaded. After that you've to type dmraid -ay to enable the RAID array. Then if the partitions do not appear, please inform the kernel of partition table change with partprobe -s. Solved and working. To keep this configuration after reboot, adapt your initramfs by adding some HOOKS. Wget (talk) 20:06, 10 August 2013 (UTC)Reply[reply]
Only got to this discussion months after installing Arch, which I achieved by repartitioning my RAID array with GParted when I had the same problem (no block devices for partitions). In my case the RAID was working in Ubuntu, but not Arch and GParted complained about several (minor?) formatting errors. After repartitioning in the Arch live environment, I could get block devices for the partitions. Since I could never get dmraid working, the partitions are managed by mdadm. I would love to see more recent tests confirming dmraid + partprobe to load the partitions. Quequotion (talk) 02:46, 16 March 2014 (UTC)Reply[reply]
I have just installed my Arch on AMD Fakeraid. Either i was doing something horribly wrong, or mdadm only works with Intel raids, not with AMD since it wouldnt detect the partitons at all. Like it was mentioned on the wiki, arch iso didnt work with dmraid so first i had to install Arch on usb drive, boot from it, get arch-install-scripts and then after regenerating initcpio i could install on my raid HDD`s --Midov (talk) 20:33, 16 November 2014 (UTC)Reply[reply]