Talk:Lenovo ThinkPad T14 (AMD) Gen 3

From ArchWiki
Latest comment: 7 March 2023 by Bakunin in topic Secure Boot with user keys

Hardware error

I'm getting Hardware Error, anyone else?

Not sure if it's genuinely a Hardware Error requiring a RMA. Hendry (talk) 06:07, 31 October 2022 (UTC)Reply[reply]

Recent amdgpu problems

Recently acquired this machine, experience sporadic screen flickering and hang ups. Cannot find a way to reproduce. Seems to be a common problem:



Issue is not solved as of 03 March 2023.

Issue is reported on Phoronix: and using amdgpu.sg_display=0 may be a fix, haven't tested yet.

Happened on 6.2.1-arch1-1.

-- Bakunin (talk) 12:20, 3 March 2023 (UTC)Reply[reply]

Secure Boot with user keys

Have anyone tried to install user keys for secure boot on this machine? I'm afraid to brick the device, but would like to use secure boot.

Bakunin (talk) 14:17, 7 March 2023 (UTC)Reply[reply]

Addition to 4. Quectel Modem for the use of gpsd.

Can somebody add this, because I'm afraid of doing it wrong - I'm not fluent with the arch wiki syntax.
I have a solution for GPS / gpsd not working.
The Manufacturer or Lenovo only enabled the serial AT port (ttyUSB0) on the Quectel modem.
I joined the Quectel forum to figure out how to enable the other modem ttyUSB ports,
to be able to use GPS /gpsd.

This is the thread to enable GPS / gpsd successfully. But better use the settings described here.
They are more recent and corrected - because there is no need to enable all the ports.
This is the manual for it. See page 117 chapter 9.2:

For a quick start (more recent and better tested version):

sudo minicom -D /dev/ttyUSB0
(when started press "ctrl+a e" to see what you type)

Issue the following command by typing it in then press return:

Exit minicom with "ctrl+a x"

After the reboot the ports should be:
/dev/ttyUSB0 (NMEA for GPS/gpsd)
/dev/ttyUSB1 (Modem AT commands)

This setting is permament - no need to do it again after reboot.
To restore to original settings use:

Never disable (0) the 3rd of the ports (AT command port)
I have no idea what happens when you disable access to this port.
Worst case - you will not be able to reconfigure your modem anymore.

Thank you.