Talk:Lenovo ThinkPad X1 Carbon (Gen 6)

From ArchWiki

Open Issues

  • Inclusion of X1C6(and Thinkpads in general) into the fwupd program:
    • Status as of 2018-07-31: the X1C6 is now supported by fwupd, but in my test with BIOS update 1.27 the firmware is downloaded and noticed by the BIOS at boot but updates don't seem to actually get applied. --Alan Orth (talk) 12:17, 31 July 2018 (UTC)Reply[reply]
      • Are you sure you have not accidentally disabled "UEFI updates from Windows" in the BIOS settings? --Mrfaber (talk) 12:15, 29 August 2018 (UTC)Reply[reply]
      • I've just successfully updated from 1.27 to 1.28 via sudo fwupdmgr update. It shut off the laptop, then displayed a progress bar(and a second one in red too, very ominous!) like it did with the update ISO on a flash drive I had used before, beeped loudly a couple of times, and rebooted. Now I'm showing version 1.28. --Mrfaber (talk) 21:12, 4 September 2018 (UTC)Reply[reply]
      • I'm seeing the same behavior as User:Aorth. I notice for myself that there is no boot entry for the firmware updater, despite copying fwupdx64.efi to my boot partition (/boot/EFI to be exact, but I've tried other locations as well). Is there some dependency on a Windows Firmware Updater on the boot drive? If so, that could be the issue because I completely wiped the drive before installing Arch. Djmoch (talk) 15:36, 14 June 2019 (UTC)Reply[reply]
        • Maybe you have the boot entries locked in UEFI? There is an option to freeze the boot entry list, maybe un-check that. You can also check with "efibootmgr -v" whether a boot entry is being generated for "Linux-Firmware-Updater". Mrfaber (talk) 18:34, 15 June 2019 (UTC)Reply[reply]
        • Verified that there was no boot entry, then used efibootmgr to create one. Prior to that I tried reinstalling fwupd and resetting BIOS to factory defaults with no success. Regardless, problem solved. Djmoch (talk) 19:28, 15 June 2019 (UTC)Reply[reply]

Fingerprint reader


See, especially the 9a branch.

Device id: 06cb:009a

Status as of 04/2018: "Init works, leds work, scan doesn't work yet"


There is another project called python-validity which aims to specifically support the 009a fingerprint reader model.

Can confirm this works on my model with the python-validityAUR package.

Mrfaber (talk) 16:38, 8 August 2020 (UTC)Reply[reply]

Other Power saving

Investigate how to get Watt usage down to ~2W like the Dell XPS 13 9360/9370, similar to the instructions on the XPS 9360 page, especially since the i915 video driver can be tweaked similarly with the Intel Graphics Module Powersaving Options since it’s also an HD 620 integrated video unit.

--Mrfaber (talk) 22:42, 18 April 2018 (UTC)Reply[reply]


Does anyone know if the NFC itself works? I think it should be listed in the Model description > Support section's feature table.

--1 (talk) 15:09, 17 August 2018 (UTC)Reply[reply]

Memory card reader

I am not sure if we can remove the section about the SD-card reader draining battery just yet.

For posterity, here it is:

You might also need to disable the Realtek memory card reader (which appears to use a constant 2-3 W) either via the BIOS or via

echo "2-3" | sudo tee /sys/bus/usb/drivers/usb/unbind

--Mrfaber (talk) 14:02, 8 September 2018 (UTC)Reply[reply]

Good catch - removing that section was unintentional. Added it back. --Unmadindu (talk) 17:53, 8 September 2018 (UTC)Reply[reply]

NVMe unsafe shutdowns

Does anyone else get non-zero "Unsafe Shutdowns" on NVMe (Model Number: LENSE30512GMSP34MEAT3TA)? smartctl on mine laptop constantly reports those, also I get frequent FS corruption errors after reboot :/

Fibocom L850-GL

The Fibocom L850-GL is no longer "Not Supported" under Linux. It needs to be switched from PCIe into USB mode to make it work. Then it starts up, but with FCC-Lock (Behaves like in Airplane Mode). That lock needs to be removed. All described here:

Similar solution but as kernel module:


BIOS logo no longer accepted

So it seems the procedure for applying a custom BIOS logo (splash screen) no longer works as of firmware 1.49 (2020-08-11) - the image is recognized and the updater asks whether to apply it, the manual update succeeds, but you still end up with the default "Lenovo" logo.

I've used the exact same logo file and filename as was previously working, so it can't be that.

Applying an update via the geteltorito-iso-on-a-USB-stick method also no longer results in graphical output of the second update stage (which requires a reboot), which would help to indicate what the error with the logo could be.

Users on the Lenovo forums also report the same issue: Set/Reset BIOS Boot Logo not working

Mrfaber (talk) 13:50, 17 October 2020 (UTC)Reply[reply]

touchpad / kernel module params via modprobe.d/

The suggestion to set synaptics_intertouch=1 in /etc/modprobe.d/ doesn't appear to work; the value is certainly being set in the module, but unlike the GRUB approach, it doesn't fix the wakeup for me. Would like feedback by other users. I also wonder if these older suggestions [1] (loading the i2c_i801 module) have become obsolete, or were actually the better choice. Adrian5 (talk) 16:15, 9 February 2021 (UTC)Reply[reply]

I have added synaptics_intertouch=1 to my grub boot options but still after a suspend, the trackpoint/mouse is not movable anymore. So it does not appear to be the solution. Also the i2c_i801 is loaded in my case. White gecko (talk) 21:12, 13 December 2021 (UTC) Update: Now I have also tried both i2c_i801 options [2], i.e. add i2c_i801, elan_i2c, and rmi_smbus, in this order to /etc/modules-load.d/touchpad.conf and blacklist i2c_i801. None of the two options helped. When adding it to the blacklist, I had no mouse at all, right after the boot. My kernel is 5.13.19-2-MANJARO. --White gecko (talk) 21:31, 13 December 2021 (UTC)Reply[reply]
Sometimes after wakeup the trackpoint and touchpad does not work. My usual workaround was to put it to suspend and wake it again. Recently not always the suspend works, and I found out, that the rmi things block the freeze process. After unloading and reloading the rmi_smbus module the suspend worked again, but the touchpad doesn't. When unloading and reloading the rmi_smbus and rmi_core modules the trackpoint and touchpad work again. In one command: sudo modprobe -r rmi_smbus rmi_core && sudo modprobe rmi_core && sudo modprobe rmi_smbus. --White gecko (talk) 18:24, 31 December 2021 (UTC)Reply[reply]

Another observation, that I have made is, that I have disabled the touchpad in the BIOS, since I usually only use the trackpoint. But still both, trackpoint and touchpad are active. --White gecko (talk) 18:24, 31 December 2021 (UTC)Reply[reply]