Talk:Lenovo ThinkPad X1 Extreme

From ArchWiki
Latest comment: 7 March 2020 by K900 in topic BIOS vs firmware

Microphone noise reduction causes distortion

This causes extreme distortion on my X1E. Not using the lines actually lets my mic sound just fine. Maybe the parameters are individual for each device? Utini2000 (talk) 11:41, 8 December 2019 (UTC)Reply[reply]


Has anyone submitted a patch upstream? I'll throw one together myself if no. Looks like we just need to add our device ID to list. K900 (talk) 15:50, 29 September 2019 (UTC)Reply[reply]

But it's been "kindly provided by Synaptics" so it must be accurate 😏. In seriousness I haven't seen one, seems like a useful patch if you want to submit one though.
Jshap70 (talk) 15:18, 30 September 2019 (UTC)Reply[reply]
It seems to have been kindly provided by Synaptics a while ago. Anyway, I've emailed linux-input@, we'll see where this goes.
K900 (talk) 16:25, 30 September 2019 (UTC)Reply[reply]
What exactly is this referring to? I tried enabling Intertouch and it actually made my touchpad experience worse (it made the cursor's framerate lower and disabled the clickpad). Does the device need to be added to some kind of list for it to work properly?
238r90jfeijwodssan (talk) 18:07, 1 October 2019 (UTC)Reply[reply]
No, it needs to be added to a list to be enabled by default. What issues are you experiencing with it? On what exact hardware/firmware? What environment?
K900 (talk) 18:15, 1 October 2019 (UTC)Reply[reply]
When I pass psmouse.synaptics_intertouch=1 to the kernel, moving the mouse with the touchpad is noticeably less smooth (it looks like it's running at a lower framerate?) but using the trackpoint or an external mouse feels the same. It also seems to disable clicking by pressing down on the touchpad, making it so I have to either tap or use the hardware buttons. Note that I'm actually using the gen 2 version of the X1E so maybe this is an issue with my device and not with the gen 1 version.
238r90jfeijwodssan (talk) 18:55, 1 October 2019 (UTC)Reply[reply]
That is a very important note, yes. Can you post the kernel log line that tells you to enable InterTouch? I'm curious what the exact model of your touchpad is. Also, are you using X11 or Wayland? Synaptics or libinput?
K900 (talk) 19:06, 1 October 2019 (UTC)Reply[reply]

Thunderbold Dock loses USB-Devices

I'm running the Thunderbolt Dock from Lenovo.

It happens from time to time, that the USB devices were not reacting anymore.

dmesg shows:

xhci_hcd 0000:09:00.0: xHCI host controller not responding, assume dead

Only a reboot of the system helps to get the USB devices working again

Has anybody the same problem, or hint how to get it working correctly?

I'm on the latest BIOS and Kernel on 5.3.1-arch1-1-ARCH

I also tried serveral workarrounds i found on the web:

  • putting device into sleep (using key on the dock)
  • replugging the thunderbolt dock

Kind regards,

Seho (talk) 11:41, 7 October 2019 (UTC)Reply[reply]

I'd start with a kernel upgrade
K900 (talk) 14:29, 7 October 2019 (UTC)Reply[reply]
I can confirm that I see this intermittently too (5.3.5-zen1-1-zen), however as far as I can tell it is a thunderbolt controller firmware issue and not a Linux one.
For me, when the dock is not working (or the dock somewhat "works" but only as usb-c not tb (no monitors)), the usb devices still will still not work even after a reboot to the UEFI menu despite normally being able to use them.
So far the best solution I have is to power off, plugin the dock, and then use the power button on the dock to start up the device. Something about this almost always forces the system to start up with the dock connected.
Jshap70 (talk) 19:25, 9 October 2019 (UTC)Reply[reply]
Okay, thanks for your reply. That was also something I was thinking about.
Unfortunately updating the firmware is currently not working with my dock here.
I got just a message from the windows fw-update software saying "dock not found". Maybe it was bad luck because i found many messages in lenovo forum from users which bricked this dock after firmware upgrade.
This seams to be a general problem with my "Thinkpad Thunderbolt3 Workstation Dock"
But some good new also.
I updated the whole system and now im using 5.3.4-arch1-1-ARCH and it has not happend again that usb devices were lost. and also the hdmi output on the dock is now working, which has never worked before. Maybe that is caused by the new kernel or the dock has just needed a power cycle.
But for now it seams like its working. When the problem occurs again I will post an update here.
Seho (talk) 09:06, 13 October 2019 (UTC)Reply[reply]
The problem happened again. USB devices were lost. I was able to see in dmesg that the thunderbolt controller crashed. unfortunately i was not able to save the messages before the whole system completely freezed.
At this point i will stop posting here and will create a post in the forum.
Seho (talk) 15:23, 14 October 2019 (UTC)Reply[reply]

BIOS vs firmware

I don't particularly care one way or the other, but Lenovo does refer to it as "BIOS" pretty much everywhere. K900 (talk) 07:28, 7 March 2020 (UTC)Reply[reply]