Talk:MSI GS65

From ArchWiki
Jump to navigation Jump to search

Unblocking wifi after sleep

When the laptop is resumed from sleep mode the killer wifi card is hard blocked by rfkill. The only way I've found to fix this by pressing the airplane mode key (FN + f10) twice. The suggested methods (using rfkill or reloading the iwlwifi module) don't work for me. Can anyone confirm this? Jorrifransen (talk) 10:47, 23 July 2018 (UTC)

Can't confirm. In my case, the FN + f10 has no effect at all. Do you have a different model? Check the serial number. Is there anything different about your setup? Bwrsandman (talk) 15:05, 23 July 2018 (UTC)

I am using bumblebee with the modesetting and nvidia driver. I'll have to check the serial number later, but it's a model for the dutch market. Jorrifransen (talk) 19:01, 5 August 2018 (UTC)
To get FN + f10 hotkey to work you probably have ACPI_OSI=! ACPI_OSI="Windows 2018" or somesuch in your kernel parameters, then you can trivially unblock WIFI and Bluetooth after suspend. Alu1 (talk) 22:18, 5 September 2018 (UTC)
Well acpi_osi="Windows 2018" worked with BIOS .10D, but now doesn't with .10E. None of these strings work either: sudo strings /sys/firmware/acpi/tables/DSDT | grep -i 'windows ' | sort. I think the main page should be updated since the suggestions do not work and have not for some time. Alu1 (talk) 20:54, 17 September 2018 (UTC)
Correction acpi_osi=! acpi_osi="Windows 2006" works, 2009 works, BUT 2012, 2013, 2015 do not.Alu1 (talk) 21:15, 17 September 2018 (UTC)

I can confirm that adding acpi_osi=! acpi_osi="Windows 2006" to the kernel parameters indeed fixes the airplane (FN + f10) key. I can also confirm that pressing this key twice will fix the airplane mode wake up. It's not an ideal solution but it's definitely better than hibernating to fix it. Bwrsandman (talk) 02:57, 15 October 2018 (UTC)

Touchpad disabled after sleep

My touchpad is occasionally being disabled after sleep. xinput --list does not show the touchpad at all anymore when this happens. Reloading the psmouse module does not seem to fix this. Is anyone else experiencing this? Jorrifransen (talk) 10:50, 23 July 2018 (UTC)

Haven't seen this happen either. Does pressing fn+f3 do anything? Bwrsandman (talk) 15:05, 23 July 2018 (UTC)

No it does not, I've also tried pressing it twice (like the airplane mode key) but this doesn't work either. Jorrifransen (talk) 19:03, 5 August 2018 (UTC)
I have since begun experiencing this. No clue what causes it. It seems to happen on any os or live cd that I try at random intervals. Bwrsandman (talk) 03:14, 15 October 2018 (UTC)
Did you have TLP enabled? Reikdas (talk) 11:58, 14 April 2019 (UTC)