Talk:Speech dispatcher

From ArchWiki
Latest comment: 8 June by Jlownie in topic Possible update required, need a tester

Possible update required, need a tester

I added an accuracy tag to the festival specific section earlier, from more testing it appears that editing this line forces speech-dispatcher to only run if the engine uncommented is running. It seems as though, by adding Festival to the conf, speechd will only run if festival is running, if not then it does nothing, I would assume this applies to other engines too (like espeak and espeak-ng) though I haven't tested this. Could someone else run this test and confirm it so I can be sure its not just a config issue on my end. Thanks. Dungeonseeker (talk) 14:26, 5 August 2023 (UTC)Reply[reply]

I found the same thing - I'm working on using Piper instead of festival and I found that if the festival module was uncommented and festival wasn't running then speech-dispatcher would fail to start up. Commenting out the festival module fixed this. Jlownie (talk) 03:35, 8 June 2024 (UTC)Reply[reply]

espeakup

When I first tried to get speech-dispatcher set up, whenever I did spd-say foo it would say "It seems your speech dispatcher is working but none of it" and then it cut off. I found this forum thread and installed espeakup and TTS worked.

I would edit this in in case it helps others, but it's not clear to me if this is the same thing being referred to with Speech dispatcher#Using_TTS_causes_the_dummy_output_module_to_speak_an_error_message. If it is the same thing, I think it would help to add that output (It seems your speech dispatcher is working but none of it) so that people can find this while searching their error message. And to add that you can install espeakup to get it working (if it's an alternative to festival in the current solution). If it's something different to that section, I'm happy to add a new section about espeakup. Revsuine (talk) 17:56, 28 March 2024 (UTC)Reply[reply]

+1 to quoting the error message.
According to Install Arch Linux with accessibility options#Install essential packages espeakup is needed. It could be that it's missing from the (optional) depends of speech-dispatcher. Perhaps, you wait a few days if @Dungeonseeker has input and add it then. --Indigo (talk) 08:33, 31 March 2024 (UTC)Reply[reply]