Talk:Steam/Game-specific troubleshooting

From ArchWiki
Latest comment: 6 May by Kode54 in topic Fall Guys

Borderlands 2

Regarding Borderlands 2 SHiFT authentication fix, I had to create the symlink to /etc/ssl in /usr/lib in order to get authentication to work, per this post: —This unsigned comment is by Soseihin (talk) 07:25, 10 April 2015‎. Please sign your posts with ~~~~!

"Alien: Isolation" and "Revenge of the Titans" didn't start without XRandr

I see that libxtst is set as dependency for "Revenge of the Titans" so maybe xrandr dependency should be replaced by libxtst. From my investigation xrandr is needed to detect displays. Soos (talk) 09:23, 11 January 2017 (UTC)Reply[reply]

Borderlands 2 and Borderlands: The Pre-Sequel crash on startup

Sometimes these games crash right after the startup and the following entries can be seen in dmesg:

 [  671.617205] Borderlands2[2772]: segfault at 0 ip           (null) sp 00000000ff9a462c error 14 in Borderlands2[8048000+235a000]
 [  680.768555] BorderlandsPreS[2784]: segfault at 0 ip           (null) sp 00000000ffb7f55c error 14 in BorderlandsPreSequel[8048000+22cd000]

In this case the following 2 steps helped me troubleshooting it (taken from here

1) Install steam-native-runtime package:

 $ sudo pacman -S steam-native-runtime

2) Add LD_PRELOAD to the launch options (Borderlands 2 -> Properties -> General -> Set Launch Options...):

 LD_PRELOAD='./$LIB/' %command%

It can also be combined with the SSL certs workaround by adding both variables to the command line:

 LD_PRELOAD='./$LIB/' SSL_CERT_DIR="/etc/pki/tls/certs" %command%

Perhaps we can add this info onto the main page, it seems like this issue might affect many users (at least the guy who I referred in the link above had exactly the same symptoms as myself). I don't know if I'm allowed to edit the main page.

—This unsigned comment is by Darkmind (talk) 22:16, 2017 January 11‎. Please sign your posts with ~~~~!

steam launch options

Is there a reason why launch options are listed following way

"echo 'hi'"

instead of

echo 'hi'

? The first with the "" doesn't work for me. --Greenbigfrog (talk) 12:21, 14 May 2017‎ (UTC)Reply[reply]

Civilization 6 crashes oddly

I've set up Civ6 on Steam exactly as described on this page. However, what happens is that the game starts, but once I go past the Sean Bean talk screen about my civilization, the game crashes. This is the relevant terminal output at crash:

connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
Game removed: AppID 289070 "Sid Meier's Civilization VI", ProcID 5578

Is this something new? KozRoss (talk) 02:39, 17 May 2017 (UTC)Reply[reply]

I had a similar error if I tried to launch the game with a USB DAC connected. Seeing that the error is generated by a call to some JACK shared memory, I think you may be having a similar problem. Has your audio setup changed? --Bumblebeer (talk) 01:05, 27 August 2018 (UTC)Reply[reply]

libopenssl-1.0-compat AUR package gone

4 games currently reference #OpenSSL 1.0 setup, which links to libopenssl-1.0-compatAUR which is no longer in the AUR.

While there is lib32-libopenssl-1.0-compatAUR, it requires the 32-bit tool chain and I am not sure if it also does the trick. --Larivact (talk) 09:05, 2 July 2017 (UTC)Reply[reply]

I think openssl-1.0/lib32-openssl-1.0 should work. Unable to check at the moment though. Lonaowna (talk) 09:39, 2 July 2017 (UTC)Reply[reply]

Torchlight 2


Would it be possible for someone to post a guide on how to get Torchlight 2 to work on Arch Linux since it does not load at all. I would appreciate someone doing Torchlight 2 troubleshooting if possible? I have found assistance on steam forum but the suggestions they provided don't usually help and sound pretty basic instructions but the game don't still work. Darkstar (talk) 21:11, 21 May 2018 (UTC)Reply[reply]

To run Torchlight 2 with the libfontconfig update installed, you need to set your launch options to
LD_PRELOAD=/usr/lib/ %command%
It should run fine after this.

---Ichio (talk)!

Hi, Just tried this now, and thank you, the game itself now works and launches as normal, now I can play this game on Arch Linux. Could someone mention this fix on the main article if possible as I'm not 100% with the mediawiki software nor interface. Regards Darkstar (talk) 16:26, 4 June 2018 (UTC)Reply[reply]

System Shock 2 not launching!

Having trouble with this game it only states "-running" and then nothing loads and doesn't launch could someone who's experienced help out please I'm trying to use this without wine and will refuse to install wine on my system but would like to play it natively I've tried it with steam-runtime & steam-native currently using steam-native on my system. Also the wiki doesn't have any fix for this game on Arch and I've had problems with it for the Ubuntu, Fedora and SteamOS systems also. I'd appreciate anyone finding a fix for this game to get it to work without the use of any "dodgy" wine software which I really don't like to use. Regards Darkstar (talk) 20:58, 6 September 2018 (UTC)Reply[reply]

Also it did use to work before the Nightdive Studio company behind the Linux version updated the actual game for Linux after then it refused to work on any Linux-based systems and the compnay who I did contacted refused to provide any further assistance stating that "its out of their hands". Darkstar (talk) 21:03, 6 September 2018 (UTC)Reply[reply]
Found fixes for the game so I've mentioned it on the main System Shock 2 section so that others know how to fix the game itself. Regards Darkstar (talk) 15:55, 14 September 2018 (UTC)Reply[reply]

DiRT Rally and the dependency hell

I got it running by pretending that some dependencies like libcurl are the version the game wants, which removes the need for the ldap compat package, but I don't have the energy to test if that's actually sane. It does run, and it seemed perfectly stable so far, but who knows what side-effects this might have. Maybe another time, plus I want to check if I can swap out SDL for a more modern version, which might fix the pipewire problem and improve latency (maybe). Thoughts and notes apprechiated, who knows when I'll want to dive into this pit of needles again.

Oh also the Steam Runtime makes it crash for me. No idea why. Not going to debug it.

RiedleroD (talk) 14:02, 18 June 2023 (UTC)Reply[reply]

Fall Guys

The game is crashing on random stages today, possibly related to the glibc updates, possibly not. Either way, adding the `-force-d3d12` switch to launch options seems to stop the crashing. (AMD Radeon RX 6700-XT) ~~~~ Kode54 (talk) 01:31, 4 May 2024 (UTC)Reply[reply]

Disregard this problem, the main problem was a kernel 6.9-rc5 commit that was backported to 6.8.9, affecting only AMD drivers if Resizable BAR is somehow disabled, and I somehow had CSM default enabled. A tentative fix is in 6.9-rc7, which I will be testing tonight with Resizable BAR disabled again, just to validate the behavior. Kode54 (talk) 21:22, 6 May 2024 (UTC)Reply[reply]