From ArchWiki
Latest comment: 21 October 2015 by Agent0 in topic Problem with new service file

Problem with new service file

I was following this article exept step of mv /usr/lib/systemd/system/tox-bootstrapd.service /etc/systemd/system I just enabled tox-bootstrapd.service. Then I made described steps: added user, made directory (it already existed due to I made it before while following old version of this article), changed owner, reloaded systemd, made /etc/tox-bootstrapd.conf file and edited bootstrap nodes to real one. Then I could not start tox-bootstrapd.service, due to inside .service file there was

ExecStart=/usr/local/bin/tox-bootstrapd /etc/tox-bootstrapd.conf

and it complained, that there is not such file, which is true. I guess that maintainer made wrong .service file. But I noticed, that there is /usr/bin/bootstrapd file and I edited .service file to point to it:

ExecStart=/usr/bin/tox-bootstrapd /etc/tox-bootstrapd.conf

I tryed to start service, but still failed. I rebooted and then tryed to start it again. Now I am expriencing another problem: it fails with status 200 and message tox-bootstrapd.service: Failed at step CHDIR spawning /usr/bin/tox-bootstrapd: No such file or directory. It is not true, I mean file really exists. I think maybe something wrong with access permissions. Can anybody help? And we need edit this article accordingly.

I have executed sudo mkdir /var/lib/tox-bootstrapd and now it fails with status 1

I saw journal of process and find there a string Couldn't read/write: /var/lib/tox-bootstrapd/keys. Exiting. I have created directory /var/lib/tox-bootstrapd/keys but still same error. Is anything wrong with permissions? That directory belongs to root, but maybe tox-bootstrapd user wants write to there... Should I change owner of that directory from root to tox-bootstrapd? — Agent0 (talk|contribs) 17:42, 16 August 2015 (UTC)Reply

Hi Henry! Thanks for your suggestion. I run chown -R tox-bootstrapd:tox-bootstrapd /var/lib/tox-bootstrapd but it did not help. — Agent0 (talk|contribs) 13:38, 21 October 2015 (UTC)Reply

Special UID when creating user

Following this article, we create a user named tox-bootstrapd, but then that user is displayed at display manager screen. This happens because that user's UID is larger than 1000. See SDDM#One or more users do not show up on the greeter. I think that instructions in this article should create user with UID less than 1000. — Agent0 (talk|contribs) 09:38, 19 August 2015 (UTC)Reply