Talk:Pantheon

From ArchWiki
Jump to: navigation, search

Rewrite the page

Most of the information on this page is either irrelevant or out of date. I also just finished porting more of Pantheon's components to the AUR and there is now a meta package (pantheon-bzr-metaAUR). --Yoshi2889 (talk) 12:37, 20 March 2016 (UTC)

Yoshi2889 what is the current recommended process to get Pantheon up and running? Happy to update the page, just need to be put on the right track. Wezm (talk) 00:17, 4 January 2017 (UTC)
Wezen it is complicated, since users first need to install gala-bzrAUR, then wingpanel-bzrAUR and switchboard-bzrAUR, then they can install the meta package. You'll get dependency errors if you don't follow this route. Plus I think appcenter-bzrAUR still doesn't build as appstream doesn't include the VAPI bindings enabled by default. I also want to see if there are stable packages around somewhere and make packages for those, but I do not know when I will have time to do that. --Yoshi2889 (talk) 01:16, 4 January 2017 (UTC)

Rewritten

I went ahead with my proposal, although I still have some doubts. We need to make sure the packages all build properly, and perhaps make some changes to them (it's probably better to make all of the *-bzr packages depend on *-bzr versions of their dependencies, even if they work with a standard release package, because it could cause problems with other packages), and some sections could use fact-checking in reference to the packages available in community and other non *-bzr packages.

To be specific:

Is it still true that pantheon-terminal has the gconf key org.pantheon.terminal.settings.opacity? Pantheon#Opacity_.28transparency.29

Are these issues still valid regarding gala-bzrAUR (there is no gala package in community or AUR): Pantheon#Gala_crashes_on_start Pantheon#I_do_not_have_any_mouse_cursor

Is wingpanel the old version, built for unity indicators, or a new release that is compatible with the modern indicators? Indicators_not_appearing_in_wingpanel

Is there still a problem with lightdm-pantheon-greeter{,-bzr}? Pantheon#Cannot_interact_with_the_LightDM_Pantheon_greeter

Does this apply only to wingpanel and the old indicators, as I have not seen it with wingpanel-bzrAUR and indicators such as glippy-indicatorAUR, indicator-sensors-gitAUR, or indicator-powersaveAUR? Pantheon#Corrupted_graphics_in_Ayatana_indicators

quequotion (talk) 16:58, 10 April 2017 (UTC)