Talk:Dell XPS 13 (9350)

From ArchWiki
Latest comment: 19 July 2017 by Lgunsch in topic Thunderbolt and XPS 15/13

Added a section for kernel specific configurations.

Keyboard backlight timeout on AC

On other XPS 13 models it's possible to change the keyboard backlight timeout. I'm not able to change the default 10s timeout value even with this:

By default, the keyboard backlight turns off after 10 seconds of inactivity. Some users might find this too short and annoying. The delay can be increased (or decreased) by editing this file:


After editing the value (to e.g. 30s) the value resets to 0s again. Has anybody found a solution for this?

BIOS update 1.1.9

Since the BIOS update, I get some errors, with stack dump during suspend/resume.

 [    0.448742] ------------[ cut here ]------------
 [    0.448744] WARNING: CPU: 1 PID: 1 at arch/x86/mm/dump_pagetables.c:225 note_page+0x5e1/0x780()
 [    0.448745] x86/mm: Found insecure W+X mapping at address ffff880000000000/0xffff880000000000
 [    0.448746] Modules linked in:
 [    0.448748] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.4.0-3-ARCH #1
 [    0.448749] Hardware name: Dell Inc. XPS 13 9350/0V33HM, BIOS 1.1.9 12/18/2015
 [    0.448750]  0000000000000000 00000000271d54da ffff8802771afd48 ffffffff812c8a99
 [    0.448752]  ffff8802771afd90 ffff8802771afd80 ffffffff810771c2 ffff8802771afe90
 [    0.448754]  8000000000000163 0000000000000004 0000000000000000 0000000000000000
 [    0.448755] Call Trace:
 [    0.448758]  [<ffffffff812c8a99>] dump_stack+0x4b/0x72
 [    0.448760]  [<ffffffff810771c2>] warn_slowpath_common+0x82/0xc0
 [    0.448762]  [<ffffffff8107725c>] warn_slowpath_fmt+0x5c/0x80
 [    0.448763]  [<ffffffff8106c4c1>] note_page+0x5e1/0x780
 [    0.448765]  [<ffffffff8106c967>] ptdump_walk_pgd_level_core+0x307/0x450
 [    0.448766]  [<ffffffff8106cae7>] ptdump_walk_pgd_level_checkwx+0x17/0x20
 [    0.448768]  [<ffffffff8106278f>] mark_rodata_ro+0xef/0x100
 [    0.448770]  [<ffffffff81586350>] ? rest_init+0x90/0x90
 [    0.448771]  [<ffffffff8158636d>] kernel_init+0x1d/0xe0
 [    0.448773]  [<ffffffff8159290f>] ret_from_fork+0x3f/0x70
 [    0.448774]  [<ffffffff81586350>] ? rest_init+0x90/0x90
 [    0.448775] ---[ end trace b1a5026ad8272458 ]---

Bouh (talk) 07:48, 20 January 2016 (UTC)Reply[reply]

Since latest kernel update (4.4.1-2-ARCH), I do not get the above error anymore. I'm still using 1.1.9 at the moment. Instead I get the following error:

[ 1370.376263] ------------[ cut here ]------------
[ 1370.376281] WARNING: CPU: 1 PID: 140 at drivers/ata/libata-eh.c:4143 ata_scsi_port_error_handler+0x731/0x770 [libata]()
[ 1370.376356] Modules linked in: fuse ipt_REJECT nf_reject_ipv4 ip6t_REJECT nf_reject_ipv6 nf_conntrack_ipv6 nf_defrag_ipv6 xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_conntrack nf_conntrack ip6t_rpfilter snd_hda_codec_hdmi ip6table_raw joydev input_leds ip6_tables mousedev iptable_filter dell_led dell_laptop intel_rapl x86_pkg_temp_thermal intel_powerclamp led_class serio_raw atkbd kvm_intel dcdbas libps2 dell_wmi hid_multitouch nls_iso8859_1 i2c_designware_platform i2c_designware_core sparse_keymap kvm nls_cp437 snd_hda_codec_realtek snd_hda_codec_generic vfat irqbypass fat crct10dif_pclmul crc32_pclmul aesni_intel snd_soc_skl snd_soc_skl_ipc snd_hda_ext_core aes_x86_64 lrw gf128mul snd_soc_sst_ipc glue_helper snd_soc_sst_dsp ablk_helper cryptd snd_soc_core snd_compress snd_pcm_dmaengine
[ 1370.376448]  ac97_bus dw_dmac_core pcspkr snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm brcmfmac snd_timer snd rtsx_pci_ms brcmutil i2c_i801 soundcore cfg80211 memstick uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common shpchp videodev mei_me btusb btrtl usbhid media mei idma64 processor_thermal_device intel_soc_dts_iosf iosf_mbi intel_lpss_pci fan thermal wmi i2c_hid hid battery hci_uart btbcm btqca btintel bluetooth i8042 rfkill serio crc16 pinctrl_sunrisepoint pinctrl_intel intel_lpss_acpi evdev acpi_als intel_lpss kfifo_buf industrialio mac_hid int3403_thermal int3400_thermal int340x_thermal_zone acpi_thermal_rel tpm_tis acpi_pad tpm ac fjes processor sch_fq_codel coretemp msr ip_tables x_tables rtsx_pci_sdmmc mmc_core xhci_pci ahci xhci_hcd libahci
[ 1370.376474]  libata rtsx_pci scsi_mod usbcore usb_common crc32c_generic crc32c_intel btrfs xor raid6_pq i915 video button intel_gtt i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm nvme
[ 1370.376480] CPU: 1 PID: 140 Comm: scsi_eh_2 Tainted: G        W       4.4.1-2-ARCH #1
[ 1370.376482] Hardware name: Dell Inc. XPS 13 9350/0V33HM, BIOS 1.1.9 12/18/2015
[ 1370.376488]  0000000000000000 000000009b4c41e3 ffff880274f23d60 ffffffff812c7f39
[ 1370.376494]  0000000000000000 ffff880274f23d98 ffffffff810765b2 ffff880274de0000
[ 1370.376499]  ffff880274f23e08 ffff880274de0000 ffff880274f23e60 ffff880274f23e80
[ 1370.376501] Call Trace:
[ 1370.376508]  [<ffffffff812c7f39>] dump_stack+0x4b/0x72
[ 1370.376516]  [<ffffffff810765b2>] warn_slowpath_common+0x82/0xc0
[ 1370.376523]  [<ffffffff810766fa>] warn_slowpath_null+0x1a/0x20
[ 1370.376533]  [<ffffffffa03944b1>] ata_scsi_port_error_handler+0x731/0x770 [libata]
[ 1370.376546]  [<ffffffffa038ed1d>] ? ata_scsi_cmd_error_handler+0x11d/0x160 [libata]
[ 1370.376557]  [<ffffffffa0394590>] ata_scsi_error+0xa0/0xe0 [libata]
[ 1370.376568]  [<ffffffffa0339246>] scsi_error_handler+0xb6/0x550 [scsi_mod]
[ 1370.376575]  [<ffffffff8158d93a>] ? __schedule+0x3aa/0xa70
[ 1370.376586]  [<ffffffffa0339190>] ? scsi_eh_get_sense+0x170/0x170 [scsi_mod]
[ 1370.376591]  [<ffffffff81093ff8>] kthread+0xd8/0xf0
[ 1370.376597]  [<ffffffff81093f20>] ? kthread_worker_fn+0x170/0x170
[ 1370.376602]  [<ffffffff81591e8f>] ret_from_fork+0x3f/0x70
[ 1370.376608]  [<ffffffff81093f20>] ? kthread_worker_fn+0x170/0x170
[ 1370.376611] ---[ end trace d11264a1acf26f7c ]---

I do not see any other errors. It's an ATA error, and I am still preloading "nvme" in my MODULES= mkinitcpio configuration at the moment.Bouh (talk) 06:03, 12 February 2016 (UTC)Reply[reply]

I can second that exact same error with 4.4.1-2-ARCH. After reading through I'm starting to begin wondering if its a general hardware problem with the mainboard/powerboard. Does anyone with an XPS 9350 NOT have any of this issues with a working suspend? --Tommyfankhauser (talk) 09:47, 12 February 2016 (UTC)Reply[reply]

BIOS 1.2.3

With BIOS update 1.2.3 I get the following ACPI errors:

 [  240.210541] INFO: task kworker/0:2:64 blocked for more than 120 seconds.
 [  240.210552]       Not tainted 4.4.1-1-ARCH #1
 [  240.210555] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
 [  240.210561] kworker/0:2     D ffff880275b13b58     0    64      2 0x00000000
 [  240.210580] Workqueue: kacpid acpi_os_execute_deferred
 [  240.210585]  ffff880275b13b58 ffffffff8137774a ffffffff81810500 ffff880275b9ac40
 [  240.210591]  ffff880275b14000 ffff880271451700 ffff880275b9ac40 ffff880276966820
 [  240.210597]  ffff88007628b050 ffff880275b13b70 ffffffff8158e03c 7fffffffffffffff
 [  240.210603] Call Trace:
 [  240.210612]  [<ffffffff8137774a>] ? acpi_ut_repair_name+0x2a/0x74
 [  240.210622]  [<ffffffff8158e03c>] schedule+0x3c/0x90
 [  240.210629]  [<ffffffff81590ab3>] schedule_timeout+0x1b3/0x240
 [  240.210633]  [<ffffffff8137774a>] ? acpi_ut_repair_name+0x2a/0x74
 [  240.210642]  [<ffffffff8136c0c6>] ? acpi_ns_search_one_scope+0x25/0x45
 [  240.210649]  [<ffffffff8136c235>] ? acpi_ns_search_and_enter+0x14f/0x1ab
 [  240.210656]  [<ffffffff8158fd34>] __down_timeout+0x74/0xd0
 [  240.210662]  [<ffffffff810bdb87>] ? down_timeout+0x37/0x60
 [  240.210666]  [<ffffffff810bdb9c>] down_timeout+0x4c/0x60
 [  240.210673]  [<ffffffff813478bf>] acpi_os_wait_semaphore+0x4c/0x67
 [  240.210679]  [<ffffffff81367243>] acpi_ex_system_wait_mutex+0x3c/0x4d
 [  240.210686]  [<ffffffff81359b28>] acpi_ds_begin_method_execution+0x13f/0x1d8
 [  240.210693]  [<ffffffff81359db4>] acpi_ds_call_control_method+0x54/0x17b
 [  240.210698]  [<ffffffff8136f3ab>] acpi_ps_parse_aml+0xaf/0x26f
 [  240.210703]  [<ffffffff8136fc11>] acpi_ps_execute_method+0x14b/0x186
 [  240.210710]  [<ffffffff8136a151>] acpi_ns_evaluate+0x1bb/0x247
 [  240.210717]  [<ffffffff8135d6f9>] acpi_ev_asynch_execute_gpe_method+0xa0/0x105
 [  240.210723]  [<ffffffff81346bce>] acpi_os_execute_deferred+0x14/0x20
 [  240.210731]  [<ffffffff8108e21b>] process_one_work+0x14b/0x440
 [  240.210737]  [<ffffffff8108e558>] worker_thread+0x48/0x4a0
 [  240.210744]  [<ffffffff8108e510>] ? process_one_work+0x440/0x440
 [  240.210750]  [<ffffffff8108e510>] ? process_one_work+0x440/0x440
 [  240.210755]  [<ffffffff81093ff8>] kthread+0xd8/0xf0
 [  240.210761]  [<ffffffff81093f20>] ? kthread_worker_fn+0x170/0x170
 [  240.210766]  [<ffffffff81591e8f>] ret_from_fork+0x3f/0x70
 [  240.210771]  [<ffffffff81093f20>] ? kthread_worker_fn+0x170/0x170

This probably stems from a malfunctioning in the 1.2.3 Bios:

 [    2.927769] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure,   AE_NOT_FOUND (20150930/psargs-359)
 [    2.927774] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.927782] ACPI Error: Method parse/execution failed [\_TZ.FN00._ON] (Node ffff8802780deed8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.927791] acpi PNP0C0B:00: Failed to change power state to D0
 [    2.931194] proc_thermal 0000:00:04.0: enabling device (0000 -> 0002)
 [    2.934430] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    2.934434] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.934439] ACPI Error: Method parse/execution failed [\_TZ.FN00._ON] (Node ffff8802780deed8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.934445] acpi PNP0C0B:00: Setting initial power state
 [    2.936690] intel-lpss 0000:00:15.0: enabling device (0000 -> 0002)
 [    2.937857] idma64 idma64.0: Found Intel integrated DMA 64-bit
 [    2.951059] acpi PNP0C0B:00: Cannot transition from (unknown) to D3hot
 [    2.951481] intel-lpss 0000:00:15.1: enabling device (0000 -> 0002)
 [    2.951616] idma64 idma64.1: Found Intel integrated DMA 64-bit
 [    2.957772] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    2.957776] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.957781] ACPI Error: Method parse/execution failed [\_TZ.FN01._ON] (Node ffff88027810f028), AE_NOT_FOUND (20150930/psparse-542)
 [    2.957787] acpi PNP0C0B:01: Failed to change power state to D0
 [    2.964451] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    2.964455] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.964460] ACPI Error: Method parse/execution failed [\_TZ.FN01._ON] (Node ffff88027810f028), AE_NOT_FOUND (20150930/psparse-542)
 [    2.964498] acpi PNP0C0B:01: Setting initial power state
 [    2.969276] mei_me 0000:00:16.0: enabling device (0000 -> 0002)
 [    2.981024] acpi PNP0C0B:01: Cannot transition from (unknown) to D3hot
 [    2.987767] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    2.987772] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.987778] ACPI Error: Method parse/execution failed [\_TZ.FN02._ON] (Node ffff88027810f168), AE_NOT_FOUND (20150930/psparse-542)
 [    2.987784] acpi PNP0C0B:02: Failed to change power state to D0
 [    2.990676] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
 [    2.994441] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    2.994447] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    2.994455] ACPI Error: Method parse/execution failed [\_TZ.FN02._ON] (Node ffff88027810f168), AE_NOT_FOUND (20150930/psparse-542)
 [    2.994464] acpi PNP0C0B:02: Setting initial power state
 [    3.001025] usb 1-3: new full-speed USB device number 3 using xhci_hcd
 [    3.007691] acpi PNP0C0B:02: Cannot transition from (unknown) to D3hot
 [    3.014415] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    3.014420] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    3.014426] ACPI Error: Method parse/execution failed [\_TZ.FN03._ON] (Node ffff88027810f2a8), AE_NOT_FOUND (20150930/psparse-542)
 [    3.014436] acpi PNP0C0B:03: Failed to change power state to D0
 [    3.018400] ACPI Warning: SystemIO range 0x000000000000F040-0x000000000000F05F conflicts with OpRegion 0x000000000000F040-0x000000000000F04F (\_SB_.PCI0.SBUS.SMBI) (20150930/utaddress-254)
 [    3.018409] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
 [    3.021070] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
 [    3.021074] ACPI Error: Method parse/execution failed [\_TZ.FNCL] (Node ffff88027810f4d8), AE_NOT_FOUND (20150930/psparse-542)
 [    3.021080] ACPI Error: Method parse/execution failed [\_TZ.FN03._ON] (Node ffff88027810f2a8), AE_NOT_FOUND (20150930/psparse-542)
 [    3.021086] acpi PNP0C0B:03: Setting initial power state

Additionally I still get the intel gpu drm error that was present in 4.3:

 [ 8200.818355] WARNING: CPU: 0 PID: 663 at drivers/gpu/drm/i915/intel_pm.c:3597 skl_update_other_pipe_wm+0x1e7/0x1f0 [i915]()
 [ 8200.818357] WARN_ON(!wm_changed)
 [ 8200.818359] Modules linked in:
 [ 8200.818361]  ...
 [ 8200.818462]  intel_gtt
 [ 8200.818466] CPU: 0 PID: 663 Comm: Xorg Tainted: G        W       4.4.1-1-ARCH #1
 [ 8200.818468] Hardware name: Dell Inc. XPS 13 9350/0PWNCR, BIOS 1.2.3 01/08/2016
 [ 8200.818470]  0000000000000000 00000000c1d62b7d ffff88007631f750 ffffffff812c7f39
 [ 8200.818474]  ffff88007631f798 ffff88007631f788 ffffffff810765b2 ffff880276862000
 [ 8200.818477]  ffff88007631f8bc ffff880276867000 0000000000000000 ffff88007631f828
 [ 8200.818480] Call Trace:
 [ 8200.818486]  [<ffffffff812c7f39>] dump_stack+0x4b/0x72
 [ 8200.818491]  [<ffffffff810765b2>] warn_slowpath_common+0x82/0xc0
 [ 8200.818495]  [<ffffffff8107664c>] warn_slowpath_fmt+0x5c/0x80
 [ 8200.818505]  [<ffffffffa00f1f37>] skl_update_other_pipe_wm+0x1e7/0x1f0 [i915]
 [ 8200.818515]  [<ffffffffa00f219a>] skl_update_wm+0x25a/0x750 [i915]
 [ 8200.818526]  [<ffffffffa00f64de>] intel_update_watermarks+0x1e/0x30 [i915]
 [ 8200.818539]  [<ffffffffa015ed70>] haswell_crtc_enable+0x370/0x870 [i915]
 [ 8200.818553]  [<ffffffffa015a992>] intel_atomic_commit+0x492/0x1430 [i915]
 [ 8200.818561]  [<ffffffffa003339e>] ? drm_atomic_check_only+0x18e/0x590 [drm]
 [ 8200.818567]  [<ffffffffa00337d7>] drm_atomic_commit+0x37/0x60 [drm]
 [ 8200.818572]  [<ffffffffa00a3fb6>] drm_atomic_helper_set_config+0x76/0xb0 [drm_kms_helper]
 [ 8200.818580]  [<ffffffffa0021ea2>] drm_mode_set_config_internal+0x62/0x100 [drm]
 [ 8200.818589]  [<ffffffffa0026d92>] drm_mode_setcrtc+0x3d2/0x4f0 [drm]
 [ 8200.818595]  [<ffffffffa00187b2>] drm_ioctl+0x152/0x540 [drm]
 [ 8200.818603]  [<ffffffffa00269c0>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
 [ 8200.818613]  [<ffffffff811f0b68>] do_vfs_ioctl+0x298/0x480
 [ 8200.818620]  [<ffffffff810824e1>] ? __set_task_blocked+0x41/0xa0
 [ 8200.818627]  [<ffffffff811fabe7>] ? __fget+0x77/0xb0
 [ 8200.818630]  [<ffffffff811f0dc9>] SyS_ioctl+0x79/0x90
 [ 8200.818634]  [<ffffffff81084fde>] ? SyS_rt_sigprocmask+0x8e/0xc0
 [ 8200.818637]  [<ffffffff81591b2e>] entry_SYSCALL_64_fastpath+0x12/0x71
 [   8200.818640] ---[ end trace 0e9f223c58ecdab8 ]---

Everything, including the graphics works fine, however I am having trouble to rewake up the system when the laptop lid was closed. If just the display is turning off, it always comes back. --Tommyfankhauser (talk) 12:45, 3 February 2016 (UTC)Reply[reply]

As of this morning, BIOS 1.2.3 and latest Linux kernel, I have no more issue with suspend/wake up. By that, I mean that I do not see the libata crash anymore on suspend/wakeup. In fact, I do not see any crashes at all. It's looking all normal. Bouh (talk) 01:01, 23 February 2016 (UTC)Reply[reply]

Nope, for me BIOS 1.2.3 with 4.4.5-1-ARCH is even worse. I can not poweroff, suspend or shutdown.--Tommyfankhauser (talk) 10:05, 16 March 2016 (UTC)Reply[reply]

I'm using the same BIOS/Kernel as you. I do see the ACPI error (namespace failure you report, but nothing else). Could it be the graphic card power management, instead? I have absolutely nothing on my kernel line (all defaults). I do load intel-ucode, and my current microcode version 0x6a. I'm not sure which version of the graphics chip you have, but the failure in intel_pm (power management of the i915) may be mitigated by "disabling" power management: have you tried putting your graphic card on always "on" power (basically disable PM):

 echo on | sudo tee /sys/bus/pci/drivers/i915/0000:00:02.0/power/control 

Hopefully, that will help you. Note that it's bus number 0000:00:02.0 on my machine, but it maybe different on yours (so you may have to inspect the /sys/bus/pci/driver/i915 tree). Bouh (talk) 10:48, 16 March 2016 (UTC)Reply[reply]

Thanks Bouh, unfortunately I already have the /power/control set to 'on'. As you, I have nothing on my kernel options but intel-ucode, no power manager, etc. Do you have any kernel modules blacklisted, such as dell_* ? I currently don't have, but maybe should? --Tommyfankhauser (talk) 12:32, 16 March 2016 (UTC)Reply[reply]

No modules blacklisted, appart from the insignificant...:

cat /etc/modprobe.d/*
blacklist pcspkr
blacklist psmouse

I'm using thermald + my own power-management scripts. I'm thinking we may have different hardware. I moved on to kernel 4.5, still no issues to report (appart from the missing ACPI namespaces). Bouh (talk) 04:31, 17 March 2016 (UTC)Reply[reply]

PulseAudio modifying gain settings

After talking to the pulseaudio mailing list, one user, gave me the workaround. This is his answer below:

 It's weird that a mic boost would affect headphone output. One
 explanation would be that the mic signal is fed directly to the
 headphones, but in that case increasing the boost should increase the
 noise, not decrease it. I guess it's a hardware or driver bug.
 To work around this, you can remove the [Element Headphone Mic Boost]
 sections from these two files:
 After that PulseAudio won't touch the boost volume any more.
 Whenever pulseaudio is updated, the package manager will remove your
 modifications, so you have to redo the modifications. That's still
 better than having to reset the mixer after every reboot...

I guess this really needs to be provided as a patched pulseaudio package. Bouh (talk) 06:09, 25 January 2016 (UTC)Reply[reply]


This is not really mentioned in the 2016 model page, but I did have some very very small icons and fonts. What I had to do was create a file and fill it with something like this:

Section "Monitor"
      Identifier             "<default monitor>"
      DisplaySize            338 190    # In millimeters

This made my DPI settings similar to what they are in the Windows (240 DPI) that came with the XPS. Renatolond

Out of curiosity, which desktop environment are you using? I am using a stock gnome-shell and it sets the scaling factor automatically. Bouh (talk) 15:34, 19 February 2016 (UTC)Reply[reply]

I'm using Plasma via SDDM, but I think the problem begins before, because in CLI without any env the fonts are very small as well. --Renatolond (talk) 16:49, 19 February 2016 (UTC)Reply[reply]

In CLI, the setting mentioned above have no effect, don't they? Check this out if you want to change this: Bouh (talk) 15:16, 1 March 2016 (UTC)Reply[reply]

What model are you using?? The actual display size should be 294 by 165 according to dell specification. By the way, I also need to set Xft.dpi: 166 in .Xresources. Jiaan (talk) 23 Sep 2016

Thunderbolt and XPS 15/13

I don't actually have a 13, but it seems the XPS 15 has somewhat similar hardware, at least as far as thunderbolt/USB-C is concerned. On my machine USB-C does not work without a PCI-e rescan, and the second you use the USB-C port the machine will no longer sleep with ACPI bugs on dmesg.

Is it crazy to just create a XPS 15 (2016) and Precision 5510 (which afaict is the same machine with higher-end processor options) page which just redirects here? —This unsigned comment is by BlueMatt (talk) 04:18, 29 March 2016‎. Please sign your posts with ~~~~!

Hi, I got exactly the same problem on my XPS 13. If I boot with USB-C adapter connected it is detectecd, if I not connects it during the boot process I need to do a rescan but if I disconnect it for the second time I got the same issue your are talking about. What is your USB-C device type your are trying to make it work? is it the Dell Multi Adatper (USB, VGA, HDMI, Ethernet)? For this one I am only able to make the Ethernet working, the HDMI is detected, my external monitor correctly detected but no signal is received on this side... Belette (talk) 14:56, 29 March 2016 (UTC)Reply[reply]

For reference, here are my related dmesg:

[  997.082343] Call Trace:
[  997.082355]  [<ffffffff812d8b11>] dump_stack+0x63/0x82
[  997.082360]  [<ffffffff81076de2>] warn_slowpath_common+0x82/0xc0
[  997.082364]  [<ffffffff81076e7c>] warn_slowpath_fmt+0x5c/0x80
[  997.082377]  [<ffffffffa00f94f7>] skl_update_other_pipe_wm+0x177/0x180 [i915]
[  997.082390]  [<ffffffffa00f968e>] skl_update_wm+0x18e/0x5f0 [i915]
[  997.082407]  [<ffffffffa018413f>] ? intel_ddi_enable_transcoder_func+0x17f/0x260 [i915]
[  997.082420]  [<ffffffffa00fcd9e>] intel_update_watermarks+0x1e/0x30 [i915]
[  997.082439]  [<ffffffffa01679a1>] haswell_crtc_enable+0x321/0x8c0 [i915]
[  997.082457]  [<ffffffffa01632b7>] intel_atomic_commit+0x737/0x1870 [i915]
[  997.082466]  [<ffffffffa0032581>] ? drm_atomic_check_only+0x181/0x600 [drm]
[  997.082473]  [<ffffffffa0032a37>] drm_atomic_commit+0x37/0x60 [drm]
[  997.082478]  [<ffffffffa00a28c6>] drm_atomic_helper_set_config+0x76/0xb0 [drm_kms_helper]
[  997.082489]  [<ffffffffa00211b2>] drm_mode_set_config_internal+0x62/0x100 [drm]
[  997.082498]  [<ffffffffa00262c0>] drm_mode_setcrtc+0x3e0/0x500 [drm]
[  997.082506]  [<ffffffffa0017892>] drm_ioctl+0x152/0x540 [drm]
[  997.082514]  [<ffffffffa0025ee0>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
[  997.082518]  [<ffffffff811eac5c>] ? __vfs_write+0xcc/0x100
[  997.082522]  [<ffffffff811fdbb1>] do_vfs_ioctl+0xa1/0x5b0
[  997.082526]  [<ffffffff81082d81>] ? __set_task_blocked+0x41/0xa0
[  997.082530]  [<ffffffff81207fc7>] ? __fget+0x77/0xb0
[  997.082534]  [<ffffffff811fe139>] SyS_ioctl+0x79/0x90
[  997.082537]  [<ffffffff810858ce>] ? SyS_rt_sigprocmask+0x8e/0xc0
[  997.082541]  [<ffffffff815ab32e>] entry_SYSCALL_64_fastpath+0x12/0x6d
[  997.082544] ---[ end trace 5285a5658ce7e2d8 ]---

Belette (talk) 15:37, 29 March 2016 (UTC)Reply[reply]

You may want to read Lots of people talking about USB-C and Thunderbolt 3. Seems display adapters work for most people with some effort, not sure about Thunderbolt 3 (which puts the USB-C port in PCIe mode), but USB-C seems pretty consistently broken in the same ways as above (I've tried it with a male A <-> C adapter and several devices, as well as my Nexus 5X which is native C). BlueMatt (talk) 18:46, 29 March 2016 (UTC)Reply[reply]

Thanks BlueMatt, I read it carefuly, and I saw the PCI rescan workaround, for me it is only working the first time then I got an issue where it will never been detected anymore and I need a system restart.

EDIT: Regarding VGA, everything is working well when connected, when it is disconnected if the laptop is put in sleep mode it hangs, no way to wake it up, power button led remains lighted but nothing on the screen.Belette (talk) 10:14, 30 March 2016 (UTC)Reply[reply]

For HDMI monitor is detected but no signal is sent so the monitor stays black, for Ethernet working if I boot the laptop with the adapter connected or if I do a rescan when I connect the adapter after the boot, but only one time...

Perhaps a good idea to add a section into the Wiki page speaking about USB-C issue/workaround? Belette (talk) 21:03, 29 March 2016 (UTC)Reply[reply]

@BlueMatt: Regarding your question of separate articles: Exactly. It is great how this article develops, even better if contributions help users of similar/related models. Please see the extra section I created earlier as a suggestion (Dell XPS 13 (2016)#Diverting models) to account for any stub model differences that may be. --Indigo (talk) 10:10, 4 April 2016 (UTC)Reply[reply]
@Belette: If you look at the Bias 1.2.3 section in this discussion, the slowpath bug is caused by a Linux kernel bug that in the meantime was fixed but reopened again ([1]). Hopefully it will be stable in 4.5.
@BlueMatt: I love that the Arch Wiki is so detailed about special models - hence I think it really depends on how similar the XPS 12, 13 and 15 models are. I have not seen any reports on how the XPS 12 works at all, only 13 and 15. Hence, I'm positive with regard to keeping separate articles until we know how similar they really are. --Tommyfankhauser (talk) 07:45, 5 April 2016 (UTC)Reply[reply]
You are welcome to add the info you have to Dell_XPS_13_(2016)#XPS_12 for now and to create an XPS12 article stub on your userpage. Open a question on the BBS, if you look for info. --Indigo (talk) 12:51, 5 April 2016 (UTC)Reply[reply]

I continuously had issues with the Dell WD15 USB-C dock connecting. Once every day or two the USB ports and the ethernet port would all disappear. I finally found out it was related to the broadcom WiFi adapter and connections issues. When my WiFi signal was bad (which was common at work), it would cause the issue. By blacklisting the brcmfmac and brcmutil kernel modules the issues totally disappeared. Lgunsch (talk) 20:04, 19 July 2017 (UTC) I tested out reducing the tx power on the WiFi adapter, but that did not fix the issue at all. I had the tx power at less than 50%, and still had issues. Lgunsch (talk) 16:21, 2 August 2017 (UTC)Reply[reply]

Touchpad multi-gesture

I don't see anything specifically related to multi-gesture (zoom, pinch...) on the touchpad in the Dell XPS 13 page.

I have installed xf86-input-libinput as suggested and both my touchpad and touch screen are working perfecty but I am missing multigesture.. Using this tips: Belette (talk) 08:28, 7 April 2016 (UTC)Reply[reply]

EFISTUB booting

I tried to get this laptop to boot the Linux kernel directly, via EFISTUB, but none of the boot entries I created with efibootmgr worked. The exact same command did work, however, from the UEFI Shell v2, as well as from systemd-boot. So I suspect that this system’s UEFI implementation doesn’t properly support passing parameters to a boot entry. For booting, you either need an UEFI boot loader (like systemd-boot), or you need to link the command line into the image, as in this article. —LucasWerkmeister (talk) 11:16, 12 June 2016 (UTC)Reply[reply]

Screen stuttering

I am experiencing quite a lot of screen stuttering. Though I have chrome running in the background, half of my memory is still free and therefore should not cause problems even for an integrated GPU. The stuttering occurs independent from the application I use: e.g. my graphical terminal (gnome-terminal) is affected as well. Temperatures seem to be fine at about 50 to 60 °C and I load the latest intel microcode through my boot loader (systemd-boot). My X11 config file looks like this:

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "sna"    # UXA is an alternative
        Option      "TearFree"     "true"   # SNA only, not needed for DRI3

Googling the issue did not return viable results since most of them concern tearing, which I do not encounter, or recommend setting the TearFree option to true which I hava already done. I am using mesa 12.0.1-2, xf86-video-intel 1:2.99.917+676+g26f8ab5-1, linux 4.6.4-1 and linux-firmware 20160516.80d463b-1 with the above xorg.conf.d/20-intel.conf config file. I assume it to be related to at least one of the packages. -- Edh (talk) 14:46, 28 July 2016 (UTC)Reply[reply]

AKiTiO Node Pro Thunderbolt 3 enclosure

I've found Linux (4.18.5) hard-locks on attachment of the Node Pro (Radeon HD 7970 inserted) when running the latest NVM26 firmware. Downgrading to NVM16 (see other versions on Dell's site for Intel_TBT3_FW_UPDATE_NVM16_8FDJ2_A06_4.16.00.005.exe) seems to resolve the issue.

I'm going to open a case with AKiTiO since my Dell support / warranty is expired.

Kaby Lake Model

Due out 4th October with intel's latest. A developer edition is coming too, bit later maybe 10th I think. Late 2016 model... Dell XPS 13 (4th Gen)